Bug 1120714 - Add documentation on Certificates
Summary: Add documentation on Certificates
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Documentation
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Released
Assignee: Sergei Petrosian
QA Contact: Melanie Corr
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-17 14:32 UTC by Eric Helms
Modified: 2019-10-07 16:45 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-05 11:38:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1291065 None CLOSED Custom certificates not correctly deployed on capsule 2019-06-18 11:54:18 UTC

Internal Links: 1291065

Description Eric Helms 2014-07-17 14:32:12 UTC
The Katello docs should include a page that describes:

1. How Katello uses certificates
2. What Certificates are generated and where they can be found
3. How to re-deploy new certificates to an existing installation

Comment 1 Eric Helms 2014-07-17 14:32:13 UTC
Created from redmine issue http://projects.theforeman.org/issues/6667

Comment 5 RHEL Product and Program Management 2015-04-21 16:11:11 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 9 Bryan Kearney 2015-08-25 17:59:06 UTC
Upstream bug component is Content Management

Comment 11 Bryan Kearney 2015-09-11 14:01:05 UTC
Upstream bug component is Content Management

Comment 13 Bryan Kearney 2015-11-05 17:01:00 UTC
Upstream bug component is Content Management

Comment 16 Bryan Kearney 2015-12-15 21:00:49 UTC
Upstream bug component is Content Management

Comment 18 Bryan Kearney 2016-01-26 19:01:11 UTC
Upstream bug component is Content Management

Comment 20 Bryan Kearney 2016-03-21 22:01:10 UTC
Upstream bug component is Content Management

Comment 23 Andrew Dahms 2017-06-22 06:10:45 UTC
Hi Eric,

Thank you for raising this bug, and my apologies that we have not been able to address it yet.

I am reviewing bugs in the queue to see what is required to address them, and wanted to clarify the current status of certificates in Satellite 6.2 and above.

Are the same certificates still generated, or have there been any changes that we should note?

Let me know if there is anything we should take note of since this bug was initially raised and discussed, and we will look into it.

Kind regards,

Andrew

Comment 24 Eric Helms 2017-07-10 17:38:52 UTC
The certificates have not changed in 6.2 and above. I think the original intent and goal of the BZ still stands.

Comment 25 Andrew Dahms 2017-08-24 08:46:44 UTC
Hi Eric,

Thank you for following up on this bug.

I am now looking to refine some of the details a little so that I can assign this out and we can work on it for an upcoming release.

Based on the content in the GitHub link, it looks like we have a table that outlines the different certificates created and the services to which they apply.

You mentioned you might be able to break down where the certificates are deployed at current. Is this something you might still be able to provide?

Kind regards,

Andrew

Comment 26 Andrew Dahms 2018-10-23 09:45:09 UTC
Updating release flag.

Comment 28 Sergei Petrosian 2019-06-05 11:38:19 UTC
I am closing this ticket because the request was made long ago and now t is time-consuming to investigate and estimate it. Please feel free to reopen the ticket if you think that the issue is relevant.

Thank you


Note You need to log in before you can comment on or make changes to this bug.