Bug 1120724 - Evolution stops showing Calendar meeting/appointment reminders
Summary: Evolution stops showing Calendar meeting/appointment reminders
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 14:54 UTC by M D
Modified: 2016-07-19 19:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 19:02:28 UTC


Attachments (Terms of Use)

Description M D 2014-07-17 14:54:39 UTC
Description of problem:

I have several different calendars in Evolution. Some are from a Google calendar, others are using caldav with owncloud.  When I first log into gnome, I get a bunch of pop-ups for past appointments. After that, I never get another reminder, either as a pop-up or in the message tray about appointments. This is obviously frustrating to not be reminded when my appointments specifically have an alarm/reminder on them.

I do get other notifications from evolution, such as a new mail notifications.

Version-Release number of selected component (if applicable):

This is an update fedora 20 with:

evolution-3.10.4-2
evolution-data-server-3.10.4-3


How reproducible:

This happens every single time. I have attempted to kill of evolution along with the other evolution processes (evolution-alarm-notify, evolution-calendar-factory), but I still don't receive notifications

Steps to Reproduce:
1. Log into gnome desktop
2.
3.

Actual results:

At login previous reminders are shown. From then on, no new calendar reminders happen.


Expected results:

New reminders should pop up or show in the message tray.

Additional info:

Comment 1 M D 2014-07-17 15:03:48 UTC
I was incorrect in one of my earlier statements. If I close evolution and manually kill off evolution-alarm-notify and evolution-calendar-factor, then start evolution again, I immediately get a pop up notification with past appointments. However, I still don't get any new notifications.

Comment 2 Milan Crha 2014-07-18 05:32:35 UTC
Thanks for a bug report. It's the evolution-alarm-notify process which is responsible for alarm notifications. If you kill/close it, then you'll not get any notifications at all. There was re-added a code to auto-start this process on evolution's start, which you obviously have (I do not recall when exactly it was re-added). In case of a crash/close of the evolution-calendar-factory the evolution-alarm-notify loses its connections to the calendars and stops notify about events in there. Can it be possible that you face something like this, the factory process crashed?

Comment 3 M D 2014-07-18 13:28:31 UTC
The evolution-alarm-notify process is running, but I am still not getting any notifications of meetings. If I kill the evolution-alarm-notify process and restart evolution, it automatically starts up the evolution-alarm-notify process and I immediately get a notification with serveral past appointments whcih I then dismiss. However, even though the evolution-alarm-notify process continues to run, I will never get another appointment notification.

Comment 4 M D 2014-07-18 15:21:44 UTC
After more testing, I have a new discovery. 

When the first notification pops up after killing evolution-alarm-notify and restarting evolution, if I right click on the title bar of the notification and click close instead of clicking the dismiss button, then I get another notification later on at the correct time for an appointment!

Apparantly the dimiss button is causing new notifications to not be shown. Is this intended? It does not seem intuitive to me.

Comment 5 Milan Crha 2014-07-21 16:52:16 UTC
Thanks for th eupdate. I tried to reproduce this with more recent evolution (current git master, which is before 3.13.4 development version release, but the code in question is the same as with 3.12.x) and I cannot reproduce this. I think your issue is most likely related to [1].

I faced an issue that I was not notified of alarms at all, when I added an event into the On This Computer/Personal calendar, which I have set for alarm notifications. But since I restarted the evolution-alarm-notify with debugging on (ALARMS_DEBUG=1 /usr/libexec/evolution/3.10/evolution-alarm-notify), I cannot let it misbehave for some reason (I changed the version in the path to your version, 3.10).

[1] https://bugzilla.gnome.org/show_bug.cgi?id=711658

Comment 6 M D 2014-07-23 15:45:33 UTC
I'm not convinced my issue is related to that upstream bug. That seemed to be more of an issue with timezones.

What I have discovered is that when a notification pops up, if I do NOT press the dimiss button, and I instead close the dialog by right clicking on the title bar and choosing close, when my next appointment comes around, I get another notification at the correct time.

However, as soon I as I press the dismiss button on a notification, I never get notifications again until I manually restart the evolution-alarm-notify process.

This doesn't seem to have any relation to the calendar source. This is true for local calendars, google calendars, and caldav calendars.

Comment 7 Fedora Admin XMLRPC Client 2014-09-04 14:30:39 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 8 Fedora End Of Life 2015-05-29 12:23:35 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 9 Jean-François Fortin Tam 2015-06-05 15:50:49 UTC
Still seeing that happening...

Comment 10 Milan Crha 2015-06-08 10:14:12 UTC
Thanks for the update. I suppose this is 3.16.2 in Fedora 22. Does this happen intermittently or you always see it for certain calendar? The calendar type might be relevant, the as whether the calendar requires a password to be opened and if yes, then whether the password is stored and "always available" or you enter the password whenever it's needed.

Comment 11 Jean-François Fortin Tam 2015-06-08 18:32:21 UTC
Hi, yep that's with 3.16.x in F22. I haven't used "local" calendars in years, I only use "Google" type remote calendars with Evolution's local caching. They are set to remember their passwords, and usually refresh every 20, 30, 60 or 120 minutes (depending on the calendar).

What typically happens is that Evolution will stop showing appointment reminders for days/weeks on end, and then suddenly one day wake up from its stupor and show me a bunch of them on startup or out of nowhere, things that are now irrelevant and part of a distant past. The result is that, unfortunately I never trust Evolution to notify me (I wish I could), I rely on Google Calendar's web interface and email notifications instead. It would be a real relief to know that I can trust Evolution/GNOME-shell to notify me at the correct times.

Searching with https://bugzilla.gnome.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&list_id=37397&product=evolution&product=Evolution%20Webcal&product=Evolution-CalDAV&product=evolution-data-server&query_format=advanced&resolution=---&short_desc=appointment%20reminder%20meeting&short_desc_type=anywordssubstr

I can see a few potentially related things, including:
- https://bugzilla.gnome.org/show_bug.cgi?id=625769 (could make sense... I always suspend/resume to/from RAM, and hop around networks; my laptop has an average uptime of 2-4 weeks)

- https://bugzilla.gnome.org/show_bug.cgi?id=689571 (I often suspected a timezones problem, but I'm not sure at all that's the cause)

And it might well be something related to processes dying, or about appointments whose notification time is during a time where Evolution was not running (I think I recall seeing a bug report about that previously, but can't find it now :(

Comment 12 Milan Crha 2015-06-09 13:54:26 UTC
It's the evolution-alarm-notify process which takes care of the notifications. I do not think gnome-shell has any own code for the reminders, they just show events for the selected day in the clock's calendar.

Either the evolution-alarm-notify is not running (for whatever reason - it is auto-started on session login and when evolution is run, but no other time), or the calendar failed to open for some reason, or got closed unexpectedly and wasn't reopened as it should.

Could you kill the current running and then run this:
   $ ALARMS_DEBUG=1 /usr/libexec/evolution/evolution-alarm-notify &>~/ean.log

and then just left it running until you notice that the evolution forgot to notify you, please? After that the log can help a bit, I hope.

> - https://bugzilla.gnome.org/show_bug.cgi?id=625769 (could make sense...
> I always suspend/resume to/from RAM, and hop around networks; my laptop
> has an average uptime of 2-4 weeks)

I'll elaborate on that upstream.

> - https://bugzilla.gnome.org/show_bug.cgi?id=689571 (I often suspected
> a timezones problem, but I'm not sure at all that's the cause)

This looks like evolution-ews specific, and there truly used to be an issue with timezones there. It doesn't influence the Google calendars, which are connected through CalDAV in the Evolution.

Comment 13 Fedora End Of Life 2016-07-19 19:02:28 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.