Bug 1120761 - xorg-x11-server-Xorg should obsolete xorg-x11-drv-mga
Summary: xorg-x11-server-Xorg should obsolete xorg-x11-drv-mga
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 15:22 UTC by Miroslav Suchý
Modified: 2014-07-21 07:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 07:34:04 UTC


Attachments (Terms of Use)

Description Miroslav Suchý 2014-07-17 15:22:31 UTC
Description of problem:
When I try to upgrade from F20 to F21 I get:
Error: Package: xorg-x11-drv-mga-1.6.2-8.fc20.x86_64 (@koji-override-0/$releasever)
           Requires: xserver-abi(videodrv-14) >= 1
           Removing: xorg-x11-server-Xorg-1.14.4-11.fc20.x86_64 (@updates/20)
               xserver-abi(videodrv-14) = 1
           Updated By: xorg-x11-server-Xorg-1.15.99.904-3.fc21.x86_64 (fedora)
              ~xserver-abi(videodrv-18) = 0

This is because xorg-x11-drv-mga has been installed by default in F20, but is not distributed any more in F21.
To provide clean update path you should put:
  Obsoletes: xorg-x11-drv-mga <= 1.6.3
in your spec file -- .3 because we need to be higher then %{versions} + dist tag.)


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.15.99.904-3.fc21.x86_64

How reproducible:
always

Steps to Reproduce:
1. From F20: yum --releasever=21 distro-sync

Comment 1 Hans de Goede 2014-07-21 07:34:04 UTC
This is fixed in xorg-x11-server-1.15.99.904-4


Note You need to log in before you can comment on or make changes to this bug.