Bug 1120762 - bootdisk seems to only support static networking
Summary: bootdisk seems to only support static networking
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 15:27 UTC by Justin Sherrill
Modified: 2019-10-10 09:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:42:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 6711 None None None 2016-04-26 16:56:44 UTC
Red Hat Knowledge Base (Solution) 1308413 None None None Never

Description Justin Sherrill 2014-07-17 15:27:29 UTC
Description of problem:

This is probably more wide spread than just bootdisk, but the following template:

https://github.com/theforeman/foreman/blob/develop/app/views/unattended/kickstart/iPXE.erb

seems to only support static networking.

<% static = @host.token.nil? ? '?static=yes' : '&static=yes' -%>

seems to indicate that static networking would be used in all cases.  In my case I did not have a subnet defined so the request to the kickstart attempted to use static networking and failed with 'undefined method mask for nil'.


How reproducible:
Always

Steps to Reproduce:
1. Create a host and do not specify a subnet (because its not needed)
2.  Attempt to provision a system with bootdisk


Actual results:
Will fail.

Expected results:
Removing the static information seems to make it work just fine.

Additional info:

Comment 1 RHEL Product and Program Management 2014-07-17 15:34:07 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-07-22 07:36:32 UTC
Created redmine issue http://projects.theforeman.org/issues/6711 from this bug

Comment 5 Bryan Kearney 2015-03-26 12:02:46 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6711 has been closed

Comment 10 Sachin Ghai 2016-05-02 09:11:01 UTC
@Marek: Hey.. as per bz description, it seems that we need to test :

1) host provisioning via generic bootdisk ?
2) bootmode should be dhcp instead of static ( as we know dhcp proxy is needed for generic bootdisk) ?

Please confirm if my assumptions are correct or if anything else needs to be tested? thanks

Comment 11 Marek Hulan 2016-05-02 10:29:19 UTC
That's my understanding as well, in other words that DHCP boot mode is supported.

Comment 12 Sachin Ghai 2016-05-02 11:51:43 UTC
Thanks Marek.

Verified with Sat6.2 beta.

I can provision a host via generic bootdisk and without defining static subnet. I associated dhcp-proxy to subnet and removed the association of tftp-proxy.

2016-04-26 02:37:40 [app] [I] Started GET "/unattended/iPXE?&mac=00%3A50%3A56%3A96%3A53%3A00" for 192.168.100.13 at 2016-04-26 02:37:40 -0400
2016-04-26 02:37:40 [app] [I] Processing by UnattendedController#host_template as HTML
2016-04-26 02:37:40 [app] [I]   Parameters: {"mac"=>"00:50:56:96:53:00", "kind"=>"iPXE"}
2016-04-26 02:37:40 [app] [I] Found sghaigenboot.cfme.lab.eng.rdu2.redhat.com
2016-04-26 02:37:40 [app] [I]   Rendered inline template (41.1ms)
2016-04-26 02:37:40 [app] [I] Completed 200 OK in 225ms (Views: 38.7ms | ActiveRecord: 24.9ms)
2016-04-26 02:37:57 [app] [I] Started GET "/unattended/provision?token=6041d2c1-0a3d-401e-bb23-6f750ff4e50d" for 192.168.100.13 at 2016-04-26 02:37:57 -0400
2016-04-26 02:37:57 [app] [I] Processing by UnattendedController#host_template as */*
2016-04-26 02:37:57 [app] [I]   Parameters: {"token"=>"6041d2c1-0a3d-401e-bb23-6f750ff4e50d", "kind"=>"provision"}
2016-04-26 02:37:57 [app] [I] Found sghaigenboot.cfme.lab.eng.rdu2.redhat.com
2016-04-26 02:38:01 [app] [I]   Rendered inline template (466.2ms)
2016-04-26 02:38:01 [app] [I] Completed 200 OK in 3746ms (Views: 440.3ms | ActiveRe

Comment 14 errata-xmlrpc 2016-07-27 08:42:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.