Bug 1120780 - [RFE] Wait for user input to shutdown vm in the end of hosted-engine deployment process
Summary: [RFE] Wait for user input to shutdown vm in the end of hosted-engine deployme...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Simone Tiraboschi
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks: 1217106 1234915
TreeView+ depends on / blocked
 
Reported: 2014-07-17 16:22 UTC by Artyom
Modified: 2016-03-09 18:51 UTC (History)
15 users (show)

Fixed In Version: ovirt-3.6.0-alpha1
Doc Type: Enhancement
Doc Text:
Users can now add an answerfile entry to enable automatic shutdown of a virtual machine at the end of the hosted engine deployment process. This allows for full automation of the process.
Clone Of:
Environment:
Last Closed: 2016-03-09 18:51:58 UTC
oVirt Team: Integration
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC
oVirt gerrit 40802 master MERGED packaging: setup: automatically shutdown engine VM on automated setup Never

Description Artyom 2014-07-17 16:22:29 UTC
Description of problem:
When you installed engine on hosted-engine-vm, and deployment process checked if engine is available, deployment print line "The system will wait until the VM is down" and wait until user manually will shutdown vm.
It was really useful to get to user choice:
(1) Shutdown vm automatically
(2) Shutdown vm manually
(3) Some other options

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.1.2-5.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Continue hosted-engine --deploy until you coming to stage "The system will wait until the VM is down"
2.
3.

Actual results:
Deployment process will wait until user shutdown vm until end of the world without give possibility to user choice to shutdown vm automatically

Expected results:
Some interact menu that will give to user possibility to choose option to shutdown vm automatically

Additional info:
Thanks to Lukas Bednar we almost have automatically hosted-engine deployment process, but because this stage not interactive, we still need to shutdown vm manually, so I also set this bug to be AutomationBlocker

Comment 1 Sandro Bonazzola 2014-07-22 14:47:09 UTC
targeting to 3.6, I suggest to backport to 3.5.z too.

Comment 2 Doron Fediuck 2014-10-01 08:21:49 UTC
Auto shutdown may be harmful is some scenarios.
The way we'll handle it is by allowing an automation flag in the answer file.

So manual installation will show the same text we have today.
However, automation using an answer file will be able to add a flag which
will auto-shutdown the VM to allow automation completion.

Comment 3 Artyom 2015-05-26 08:11:21 UTC
Verified on ovirt-hosted-engine-setup-1.3.0-0.0.master.20150518075146.gitdd9741f.el7.noarch
Add line to answer file:
OVEHOSTED_VM/automateVMShutdown=bool:True
Vm shutdowned automatically.

Comment 5 Ilanit Stein 2015-06-03 09:44:01 UTC
Adding test coverage flag "-", as there is no need for a test plan.

Comment 7 errata-xmlrpc 2016-03-09 18:51:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html


Note You need to log in before you can comment on or make changes to this bug.