Bug 1120795 - oo-install is broken as of 7/17
Summary: oo-install is broken as of 7/17
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Installer
Version: 2.x
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: N. Harrison Ripps
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 17:46 UTC by Nicholas Nachefski
Modified: 2015-05-15 02:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 14:01:43 UTC


Attachments (Terms of Use)

Description Nicholas Nachefski 2014-07-17 17:46:50 UTC
Description of problem:
oo-install bombs out when everything should be OK.


Version-Release number of selected component (if applicable):

oo-install-origin-20140717-1525.tgz

How reproducible:
run oo-install and attempt to install OSO.  This worked fine lastnight 7/16.

Actual results:
Checking broker.example.net:
* SSH connection succeeded
* Target host does not appear to be of these types: , 
Checking node01.example.net:
* SSH connection succeeded
* Target host does not appear to be of these types: , 
The deployment check was not successful. See above for specific issues.
oo-install exited; removing temporary assets.

Comment 1 N. Harrison Ripps 2014-07-17 17:51:11 UTC
Hey there--
What is the OS of your target system?

Note that oo-install has just been updated as of today to OpenShift Origin version 4. Origin v4 supports RHEL and CentOS target systems, but no longer supports Fedora (as per https://www.openshift.com/blogs/openshift-origin-road-map-doubling-down-on-developer-enablement-with-centos)

So, please let me know if this was a Fedora system. If so, there is still a bug here because the error output did not list the allowed target host types.

--Harrison

Comment 2 Nicholas Nachefski 2014-07-17 17:52:45 UTC
Yep, F19.

Comment 3 N. Harrison Ripps 2014-07-17 17:54:49 UTC
Okay, thanks. I'll take this and treat it as a requirement to improve the error reporting in oo-install.

Comment 4 N. Harrison Ripps 2014-07-18 14:01:43 UTC
Error reporting corrected: https://github.com/openshift/openshift-extras/pull/407


Note You need to log in before you can comment on or make changes to this bug.