Bug 11208 - Installer fails if incorrect partition info in /etc/fstab
Summary: Installer fails if incorrect partition info in /etc/fstab
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-03 19:14 UTC by Daniel Rogers
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 19:18:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Rogers 2000-05-03 19:14:23 UTC
When performing a RH 6.2 upgrade, if the /etc/fstab on the target HD lists
a partition as containing an ext2 filesystem when it doesn't, the installer
will fail.

What I had done was to copy a RH 4.2 install from a drive containing three
partitions to a drive that only contained two.  This left the swap
partition as /dev/hda2 instead of /dev/hda3.  when I ran the installer and
tried to upgrade the new drive, it attempted to mount /dev/hda2 as an ext2
partition.  This failed.  However, it should probably have a better failure
method that just stopping (in the X installer) or halting the system (in
the curses one).

Comment 1 Jay Turner 2000-05-03 20:34:59 UTC
Verified in test lab.  Installer should definitely handle this situation a
little more gracefully.

Comment 2 Michael Fulbright 2000-06-12 19:18:52 UTC
Should be fixed in latest internal release, passed to test lab for verification.


Note You need to log in before you can comment on or make changes to this bug.