Bug 1120805 - User required to input subnet information configured via katello-installer twice
Summary: User required to input subnet information configured via katello-installer twice
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 18:19 UTC by Rich Jerrido
Modified: 2017-08-01 20:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:34:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 4994 None None None 2016-12-19 18:04:49 UTC

Description Rich Jerrido 2014-07-17 18:19:13 UTC
Description of problem:

When installing Satellite 6 beta with the DHCP proxy, the information (gateway, dns) for the subnet that is specified via the various --dhcp* switches needs to be specified again when importing the subnet via the UI. 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install Satellite 6 with the DHCP proxy enabled. In my case I used:

katello-installer -v \
  --capsule-dns true \
  --capsule-dns-interface eth0 \
  --capsule-dns-zone example.org \
  --capsule-dns-forwarders 172.17.13.1 \
  --capsule-dns-reverse 13.17.172.in-addr.arpa \
  --capsule-dhcp true \
  --capsule-dhcp-interface eth0 \
  --capsule-dhcp-range "172.17.13.100 172.17.13.150" \
  --capsule-dhcp-gateway 172.17.13.1 \ 
  --capsule-dhcp-nameservers 172.17.13.2 \
  --capsule-tftp true \
  --capsule-tftp-servername $(hostname) \ 
  --capsule-puppet true \
  --capsule-puppetca true


2. Login to Satellite using the provided credentials. 
3. Select Infrastructure -> Capsules
4. Select the drop-down on the right of the screen
5. Select Import Subnets. 
  

Actual results:

The user is prompted to (re)enter information (gateway, dns, start/end ip range) regarding this imported subnet, even though it was provided at install time. 

Expected results:

The imported subnet should contain all the previously provided information when it is imported and only prompt for information that is not known.


Additional info:

Comment 1 RHEL Product and Program Management 2014-07-17 18:33:44 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Bryan Kearney 2017-08-01 20:34:04 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.