Bug 112081 - keyboard selection is not used for console
keyboard selection is not used for console
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-14 05:10 EST by Bart Martens
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:49:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Martens 2003-12-14 05:10:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
After installing Fedora Core 1 on my old i586, booting with the
bootdisk.img diskette, starting with boot: linux isa text expert
reboot=bios, with only "text based internet" selected in the package
groups, and after selecting keyboard layout "be-latin1" during the
installation process, I end up with some other console keyboard layout.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take an old i586, and blow off the dust.
2. Start the installation with a bootdisk.img diskette.
3. Enter "linux isa text expert reboot=bios" at the boot:-prompt.
4. Select be-latin1 as the keyboard layout.
5. Select only "text based internet" on the packages selection.



Actual Results:  The console keyboard layout is not be-latin1.


Expected Results:  Console keyboard layout be-latin1.


Additional info:

This problem did not occur with Red Hat 9; it was introduced with
Fedora Core 1.

Workaround: loadkeys /lib/kbd/keymaps/i386/azerty/be-latin1.map.gz
Comment 1 Bart Martens 2003-12-14 06:43:08 EST
A more complete workaround is manually putting the following line into
the /etc/sysconfig/keyboard file.
KEYTABLE=be-latin1
Comment 2 Bart Martens 2003-12-28 09:27:42 EST
The installer doesn't always ask for the keyboard layout. That may be
considered as another bug. For example, when I just hit the enter key
at the boot:-prompt, so without entering "linux isa text expert
reboot=bios", then the installer continues in text-modus, because my
i586 is a bit old and weak for the graphical installer. It's OK to run
in text-modus, but it's not OK that the installer doesn't ask for the
keyboard layout.

Anyhow, when the installer ask for the keyboard layout, then the
answer should be used. That is the original bug of this bug report.
Comment 3 Jeremy Katz 2004-10-05 11:49:03 EDT
This should be better now

Note You need to log in before you can comment on or make changes to this bug.