Bug 1120828 - logcheck doesn't have permossions to read logs
Summary: logcheck doesn't have permossions to read logs
Keywords:
Status: CLOSED DUPLICATE of bug 1062147
Alias: None
Product: Fedora
Classification: Fedora
Component: logcheck
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 19:37 UTC by John Ellson
Modified: 2017-01-28 15:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 09:24:03 UTC


Attachments (Terms of Use)

Description John Ellson 2014-07-17 19:37:15 UTC
Description of problem:
logcheck doesn't have permissions to read logs

Version-Release number of selected component (if applicable):
logcheck-1.3.14-9.fc20.noarch


How reproducible:
100%

Steps to Reproduce:
1.sudo -u logcheck logcheck -o -t
2.
3.

Actual results:
Error: Could not run logtail or save output.


Expected results:
Summary of interesting log messages

Additional info:
Tried:
    chown root:adm /var/log/messages; chmod 640 /var/log/messages
but something change them back withun seconds.

Tried:
    setfacl -m u:logcheck:r /var/log/messages
but the effect permissions didn't change - no acl on default mounts.

Comment 1 Matthias Runge 2014-07-18 09:24:03 UTC
Yes, that's a known issue, you need some additions tweaking; sadly, there's not much I can do about it.

*** This bug has been marked as a duplicate of bug 1062147 ***

Comment 2 John Ellson 2014-07-18 13:46:41 UTC
Then why close the bug?   Why not leave it open until someone fixes it, or removes the useless package?

Comment 3 Matthias Runge 2014-07-21 11:23:53 UTC
It's a configuration issue on your system.

Add to  /etc/logrotate.d/syslog:
create 0640 root adm

that makes /var/log/messages to be created with the appropriate ownerships.


Note You need to log in before you can comment on or make changes to this bug.