Bug 1120837 - [RFE] Satellite 6 should have a means to limit synchronization speed
Summary: [RFE] Satellite 6 should have a means to limit synchronization speed
Keywords:
Status: CLOSED DUPLICATE of bug 1348572
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1113237 (view as bug list)
Depends On:
Blocks: sat-nextgen
TreeView+ depends on / blocked
 
Reported: 2014-07-17 20:04 UTC by Rich Jerrido
Modified: 2019-07-11 08:04 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 13:18:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 448713 None None None 2017-06-29 02:55:32 UTC
Red Hat Knowledge Base (Solution) 1224523 None None None Never
Red Hat Bugzilla 1348570 None CLOSED RFE: Add documentation for max_speed on pulp yum import plugin 2019-08-09 19:22:56 UTC

Internal Links: 1348570

Description Rich Jerrido 2014-07-17 20:04:50 UTC
Description of problem:

This RFE requests the ability to have pulp throttle the network speed of its synchronization tasks, as well as exposing that capability to the user via the UI/API/CLI. Optimally, this capability would be configurable either per-repo, per-product (possibly?), or globally for the satellite instance. 

Having this capability will allow the user to throttle synchronization tasks to not monopolize network bandwidth or to stay within their SLA contraints.

Comment 1 RHEL Product and Program Management 2014-07-17 20:34:17 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Michael Hrivnak 2015-03-05 13:42:38 UTC
Pulp offers this now. There are improvements we'd like to make to how we expose download configuration items in general, but this feature is at least available and documented. It can be set in the same places that proxy settings go, if you're familiar with that.

See "max_speed" here: https://pulp-rpm.readthedocs.org/en/latest/tech-reference/yum-plugins.html#configuration-parameters

The important thing to know is that the limit is per sync task. If you run a bunch of syncs at the same time on a bunch of different workers, each one will use up to its full limit without considering the others. We've toyed with the idea of having one global limit, but that would be very difficult to coordinate in a distributed architecture. That sort of aggregate limiting might be better done in a proxy.

Comment 7 Bernie Hoefer 2015-03-05 13:57:12 UTC
(In reply to Michael Hrivnak from comment #6)
===
> See "max_speed" here:
> https://pulp-rpm.readthedocs.org/en/latest/tech-reference/yum-plugins.
> html#configuration-parameters
===

Thank you, Michael.

===
> The important thing to know is that the limit is per sync task.
===

Yes, yum's "throttle" value in /etc/yum.conf works the same way.

Should we recommend to customers who are wanting a global limit to use iptables or firewalld to limit the rate of traffic from the these IP addresses (obtained from KCS Solution 1362093)?

download.rhn.redhat.com   209.132.183.193
satellite.rhn.redhat.com  209.132.183.191
xmlrpc.rhn.redhat.com     209.132.183.192

Comment 8 Mike McCune 2015-03-12 15:11:50 UTC
Will work to get docs for 6.2 to detail how to configure Satellite 6 to use the Pulp configiruation

Comment 13 Bryan Kearney 2016-07-08 20:19:00 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 15 Rich Jerrido 2016-07-15 21:02:43 UTC
https://access.redhat.com/articles/2387381 covers how to set this up in satellite 6.1 and 6.2 until there is support in the installer (either to set the config, or to preserve it)

Comment 16 Bryan Kearney 2017-02-07 17:52:47 UTC
*** Bug 1113237 has been marked as a duplicate of this bug. ***

Comment 17 Sean O'Keeffe 2017-05-30 13:18:10 UTC

*** This bug has been marked as a duplicate of bug 1348572 ***


Note You need to log in before you can comment on or make changes to this bug.