Bug 1120877 - Rubygem-Staypuft: Deployment of Nova with LVM driver backend gets stuck when using VMs.
Summary: Rubygem-Staypuft: Deployment of Nova with LVM driver backend gets stuck when...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Dan Radez
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 21:56 UTC by Alexander Chuzhoy
Modified: 2016-04-26 15:06 UTC (History)
5 users (show)

Fixed In Version: rhel-osp-installer-0.1.6-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 18:35:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Alexander Chuzhoy 2014-07-17 21:56:25 UTC
Rubygem-Staypuft:  Deployment of Nova with LVM gets stuck when using VMs.

Environment:
rhel-osp-installer-0.1.1-1.el6ost.noarch
openstack-foreman-installer-2.0.15-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
ruby193-rubygem-staypuft-0.1.18-1.el6ost.noarch
openstack-puppet-modules-2014.1-19.1.el6ost.noarch


Steps to reproduce:
1. install rhel-osp-installer
2. Create a deployment of Nova network with 2 hosts (1 controler + 1 compute)
3. For cinder service chose LVM as Driver Backend.

Result:
The deployment gets stuck installing the controller.

Expected result:
The deployment should complete with no issues.


Revealed the following during investigation:
Inside the provisoning template, there's the following code:
  <% if @dynamic -%>
  %include /tmp/diskpart.cfg
  <% else -%>
  <%= @host.diskLayout %>
  <% end -%>

Selecting LVM as Driver Backend causes the above to be interpreted as:
  part /boot --fstype ext3 --size=500 --ondisk=sda
  part swap --size=1024 --ondisk=sda
  part pv.01 --size=102400 --ondisk=sda
  part pv.02 --size=1 --grow --ondisk=sda
  volgroup vg_root pv.01
  volgroup cinder-volumes pv.02
  logvol  /  --vgname=vg_root  --size=1 --grow --name=lv_root

On virtual machines the disk is named VDA, hence the provisioning fails.

Comment 2 Scott Seago 2014-07-18 00:23:52 UTC
This seems to be related to the recently-added LVM with cinder-volumes Ptable. @dynamic is defined in the foreman codebase as:
    @dynamic   = @host.diskLayout =~ /^#Dynamic/

Apparently, this ends up being true for the new LVM Ptable.

Comment 6 Alexander Chuzhoy 2014-07-23 17:51:29 UTC
Verified: FailedQA

Reproduced with liveCD version rhelosp-installer-live-6.5-20140722.0.iso.

Comment 7 Dan Radez 2014-07-24 15:32:33 UTC
https://github.com/theforeman/foreman-installer-staypuft/pull/53

merged upstream

Comment 9 Alexander Chuzhoy 2014-07-25 16:40:56 UTC
Verified:rhel-osp-installer-0.1.4-1.el6ost.noarch

The reported issue doesn't reproduce - was able to deploy on VMs.

Comment 10 errata-xmlrpc 2014-08-04 18:35:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.