Bug 112088 - microcode_ctl complaining about char-major-10-184
microcode_ctl complaining about char-major-10-184
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
3
i586 Linux
low Severity low
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-14 07:17 EST by Bart Martens
Modified: 2015-01-04 17:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 00:10:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Martens 2003-12-14 07:17:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
Message appearing during boot:

Applying Intel IA32 Microcode update: modprobe: modprobe: Can't locate
module char-major-10-184 [  OK  ]

When I do "/etc/init.d/microcode_ctl restart" then I see:

Applying Intel IA32 Microcode update: [  OK  ]

But, in /var/log/messages I still see:

Dec 14 13:08:49 localhost modprobe: modprobe: Can't locate module
char-major-10-184
Dec 14 13:08:49 localhost microcode_ctl: microcode_ctl startup succeeded



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take an old i586, and blow off the dust.
2. Start the installation with a bootdisk.img diskette.
3. Enter "linux isa text expert reboot=bios" at the boot:-prompt.
4. Select only "text based internet" on the packages selection.
5. Stare at the boot messages.
6. /etc/init.d/microcode_ctl restart
7. Look at /var/log/messages.




Actual Results:  Message "modprobe: Can't locate module
char-major-10-184" appearing.



Expected Results:  Message "modprobe: Can't locate module
char-major-10-184" not appearing.


Additional info:

Importance unknown.
No loss of function seen.
Not known whether the microcode update succeeded or not.
No workaround known.
Comment 1 Theodore C. Belding 2004-01-12 01:18:17 EST
I see this as well, on booting a Dell OpiPlex XL 590, and can also
reproduce it by restarting microcode_ctl:

[root@louisa root]# /etc/init.d/microcode_ctl restart
Applying Intel IA32 Microcode update:                      [  OK  ]
[root@louisa root]#

Jan 12 01:15:50 louisa modprobe: modprobe: Can't locate module
char-major-10-184
Jan 12 01:15:50 louisa microcode_ctl: microcode_ctl startup succeeded

[root@louisa root]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 5
model           : 2
model name      : Pentium 75 - 200
stepping        : 5
cpu MHz         : 90.029
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : yes
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8
bogomips        : 179.40
Comment 2 David Olmsted 2004-01-19 13:55:22 EST
Also on Pentium 4.(Dell precision) Red Hat 7.2

[root@ip68-9-128-179 log]# date
Mon Jan 19 13:25:47 EST 2004
[root@ip68-9-128-179 log]# /etc/init.d/microcode_ctl restart
Applying Intel IA32 Microcode update:                      [  OK  ]
[root@ip68-9-128-179 log]# tail -2 /var/log/messages
Jan 19 13:25:57 ip68-9-128-179 modprobe: modprobe: Can't locate module
char-major-10-184
Jan 19 13:25:57 ip68-9-128-179 microcode_ctl: microcode_ctl startup
succeeded
[root@ip68-9-128-179 log]# cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 15
model		: 1
model name	: Intel(R) Pentium(R) 4 CPU 1.70GHz
stepping	: 2
cpu MHz		: 1694.889
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips	: 3381.65

Comment 3 Need Real Name 2004-01-22 03:01:35 EST
I get this modprobe error sometimes too on my i586, however it at
least seems to be intermittent and rare in occurence for me, IA32
Microcode Update normally at least indicates it loads [OK] on boot.

[gulo@joker gulo]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 5
model           : 4
model name      : Pentium MMX
stepping        : 3
cpu MHz         : 232.275
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : yes
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 mmx
bogomips        : 463.66
Comment 4 Need Real Name 2004-01-22 10:52:41 EST
RE above comment, modprobe error is no longer intermittent on that
machine, says it can't locate the module char-major-10-184 every boot
now, this change possibly happened after an up2date.
Comment 5 Dave Jones 2004-01-22 14:06:54 EST
586 CPU's don't have the microcode feature at all, so microcode_ctl
shouldn't be doing anything at all in this situation.
Comment 6 Paul Tibbitts 2004-02-24 20:14:27 EST
I get his on my toshiba P1 266 notebook at every boot.  I'm guessing
this is a module dependency or aliasing problem, nothing to do with
microcode.  

Paul
Comment 7 Homayoun Shahri 2004-02-28 02:29:46 EST
a solution to this problem is to do:
chmod 644 /dev/cpu/0/microcode
Comment 8 Dave Jones 2004-11-27 00:12:49 EST
still a problem in fc3 ?
Comment 9 Dave Jones 2004-11-28 16:09:43 EST
for rawhide, I've added a check for < 686's that makes microcode_ctl exit
immediately.
Comment 10 Theodore C. Belding 2005-01-14 02:28:01 EST
Seems to work for me in FC3

Note You need to log in before you can comment on or make changes to this bug.