Bug 1120884 - in memory font corruption (was: Carlito font glyphs mis-assigned in 11pt)
Summary: in memory font corruption (was: Carlito font glyphs mis-assigned in 11pt)
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 22:08 UTC by Przemek Klosowski
Modified: 2014-08-08 17:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 15:01:56 UTC


Attachments (Terms of Use)

Description Przemek Klosowski 2014-07-17 22:08:42 UTC
Description of problem:
calibri fonts are misconfigured

Version-Release number of selected component (if applicable):
libreoffice-4.2.5.2-5.fc20.x86_64


How reproducible: every time


Steps to Reproduce:
1. open a libreOffice document (spreadsheet, text document)
2. change font to Calibri 11 pt
3. type 'abc'

Actual results: the display will read    JMN


Expected results: the display will read    abc

Additional info: only point size 11 is affected; if one selects the text and changes font size to 10.5 pt or 12pt or (I think) any other point size, the underlying text displays correctly as 'abc'

Comment 1 Caolan McNamara 2014-07-18 09:25:00 UTC
With the "real" Calibri or with the default replace of Carlito.

(i.e. what's the output of fc-match Calibri)

I have to say that I can't reproduce this on two F-20 boxes, one with the true Calibri installed and one with Carlito available as a replacement

Comment 2 Przemek Klosowski 2014-07-18 20:37:57 UTC
Carlito-Regular.ttf: "Carlito" "Regular"

Comment 3 Caolan McNamara 2014-07-21 10:31:40 UTC
So, your problem is with Carlito. i.e. if you change the font to Carlito does the problem persist?

I don't see any problem like this, and this should be a super common experience, so there is something unusual at your end.

Comment 4 Parag Nemade 2014-07-21 13:07:36 UTC
I can't reproduce this on F20 system. Please check again if this really is a problem.

Comment 5 David Tardon 2014-07-24 12:31:09 UTC
I cannot reproduce this either. Are you absolutely sure that your fonts are intact? What happens if you do the same thing in Abiword?

Comment 6 Przemek Klosowski 2014-07-24 15:01:56 UTC
I cannot reproduce this behavior now, either. I noticed it in a spreadsheet I received from Windows; it was unreadable, and I tracked the reason down to the simple case I reported. I could reproduce the buggy behavior repeatedly then, but it seems to work OK now, including the spreadsheet that showed the bug originally.

I had LibreOffice loaded into memory--it is quite possible that I did not reload it while trying the bug, so it could have been a corruption of the font in the memory of a running application.

Comment 7 Przemek Klosowski 2014-08-08 17:11:13 UTC
I can confirm that this looks like in-memory font corruption. 

I usually keep several docs open for several days, and it just happened to me again that incorrect glyphs are being displayed. Closing and opening the file doesn't help---I have to close all instances of oocalc. The newly run spreadsheet displays the strings correctly.

Should I  reopen this bug or just let it remain closed because this is not a repeatable problem in the new formulation--I don't know what causes the corruption.


Note You need to log in before you can comment on or make changes to this bug.