Bug 1120895 - [RFE] New Kickstart %pre-packages directive
Summary: [RFE] New Kickstart %pre-packages directive
Keywords:
Status: CLOSED DUPLICATE of bug 1120554
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 23:28 UTC by Wade Mealing
Modified: 2018-12-09 18:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 20:44:31 UTC


Attachments (Terms of Use)

Description Wade Mealing 2014-07-17 23:28:50 UTC
Description of problem:

A new directive (similar to pre) which is run after disk partitioning and mounting may allow systems to make early-install changes to the disk before packages are installed.

This would be useful in situations such as https://bugzilla.redhat.com/show_bug.cgi?id=1113885 . 

Version-Release number of selected component (if applicable):

anaconda-19.31.79-1.el7

Comment 3 David Cantrell 2014-07-23 20:44:31 UTC
Duping this to 1120554.  Adding a new special %pre section in kickstart is not the right idea.  This needs discussion and design and it may end up being in anaconda or not.  Continue the discussion in 1120554.

*** This bug has been marked as a duplicate of bug 1120554 ***


Note You need to log in before you can comment on or make changes to this bug.