Bug 1120899 - FormatCreateError: ('invalid device specification', '/dev/sda3')
Summary: FormatCreateError: ('invalid device specification', '/dev/sda3')
Keywords:
Status: CLOSED DUPLICATE of bug 1109244
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f565c3653935ae7d8b2e72c088d...
Depends On:
Blocks: F21PPCAlpha
TreeView+ depends on / blocked
 
Reported: 2014-07-18 00:13 UTC by Chris Murphy
Modified: 2014-10-07 21:05 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-07 21:05:33 UTC


Attachments (Terms of Use)
File: anaconda-tb (582.93 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: anaconda.log (23.54 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: environ (458 bytes, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: lsblk_output (1.48 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: nmcli_dev_list (1.08 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: os_info (377 bytes, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: program.log (24.33 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: storage.log (161.25 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: syslog (82.01 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: ifcfg.log (1.90 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details
File: packaging.log (235.50 KB, text/plain)
2014-07-18 00:13 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2014-07-18 00:13:08 UTC
Description of problem:
Crashes when formatting /dev/sda3 EFI system partition.

Version-Release number of selected component:
anaconda-21.48-1

The following was filed automatically by anaconda:
anaconda 21.48-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/__init__.py", line 370, in create
    raise FormatCreateError("invalid device specification", self.device)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 818, in create
    DeviceFormat.create(self, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 554, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 354, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 216, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 178, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
FormatCreateError: ('invalid device specification', '/dev/sda3')

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-21-x86-64 elevator=deadline nomodeset enforcing=0
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.0-0.rc5.git1.1.fc21.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        21

Potential duplicate: bug 1109914

Comment 1 Chris Murphy 2014-07-18 00:13:10 UTC
Created attachment 918862 [details]
File: anaconda-tb

Comment 2 Chris Murphy 2014-07-18 00:13:11 UTC
Created attachment 918863 [details]
File: anaconda.log

Comment 3 Chris Murphy 2014-07-18 00:13:12 UTC
Created attachment 918864 [details]
File: environ

Comment 4 Chris Murphy 2014-07-18 00:13:12 UTC
Created attachment 918865 [details]
File: lsblk_output

Comment 5 Chris Murphy 2014-07-18 00:13:13 UTC
Created attachment 918866 [details]
File: nmcli_dev_list

Comment 6 Chris Murphy 2014-07-18 00:13:14 UTC
Created attachment 918867 [details]
File: os_info

Comment 7 Chris Murphy 2014-07-18 00:13:14 UTC
Created attachment 918868 [details]
File: program.log

Comment 8 Chris Murphy 2014-07-18 00:13:15 UTC
Created attachment 918869 [details]
File: storage.log

Comment 9 Chris Murphy 2014-07-18 00:13:16 UTC
Created attachment 918870 [details]
File: syslog

Comment 10 Chris Murphy 2014-07-18 00:13:17 UTC
Created attachment 918871 [details]
File: ifcfg.log

Comment 11 Chris Murphy 2014-07-18 00:13:18 UTC
Created attachment 918872 [details]
File: packaging.log

Comment 12 Richard S. Hendershot 2014-07-19 13:28:33 UTC
Another user experienced a similar problem:

use boot.iso and choose check and install.  select minimal install.  select home, root, boot and swap partitions pre-existing and format and label.  during installation formatting of the VDI this bug occurs.  It's not happening in the boot.iso at branch date.  Using latest vbox 4.3.14 X64 but 32-bit install

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-21-i386 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.16.0-0.rc5.git1.1.fc21.i686
package:        anaconda-21.48-1
product:        Fedora
reason:         FormatCreateError: ('invalid device specification', '/dev/sda1')
release:        Cannot get release name.
version:        21

Comment 13 Richard S. Hendershot 2014-07-19 13:59:03 UTC
reformatted swap,sda1,5,6 partitions (boot, root, home) so they were empty and shrunk the VDI and did not experience the problem.  It has seemed somewhat random so this may not be a Fix.

Comment 14 Andre Robatino 2014-07-25 13:19:14 UTC
Another user experienced a similar problem:

Just after installation started, while trying to enter root password, clicked in first entry window to put focus there, typed in password, hit enter, got this error

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-2 rootfstype=auto ro rd.live.image rd.luks=0 rd.md=0 rd.dm=0 enforcing=0
hashmarkername: anaconda
kernel:         3.16.0-0.rc5.git1.1.fc21.x86_64
other involved packages: python-blivet-0.61-1.fc21.noarch, python-libs-2.7.7-2.fc21.x86_64
package:        anaconda-core-21.48-1.fc21.x86_64
packaging.log:  
product:        Fedora
reason:         FormatCreateError: ('invalid device specification', '/dev/sda1')
release:        Fedora release 21 (Twenty One)
version:        21

Comment 15 satellitgo 2014-07-29 20:46:46 UTC
Another user experienced a similar problem:

custom partitioning create atumatically ext "std formatting"

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-SoaS-x86_64-21-20140 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.16.0-0.rc6.git3.1.fc21.x86_64
other involved packages: python-blivet-0.61-1.fc21.noarch, python-libs-2.7.7-2.fc21.x86_64
package:        anaconda-core-21.48.1-1.fc21.x86_64
packaging.log:  
product:        Fedora
reason:         FormatCreateError: ('invalid device specification', '/dev/sda3')
release:        Fedora release 21 (Twenty One)
version:        21

Comment 16 birger 2014-07-30 11:35:31 UTC
Another user experienced a similar problem:

during install of f21 daily build. I had set up partitioning and started installation. I was setting the root password when the installer crashed.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Workstation-x86_64-2 ro rd.live.image quiet rhgb rd.live.check
hashmarkername: anaconda
kernel:         3.16.0-0.rc6.git2.1.fc21.x86_64
other involved packages: python-blivet-0.61-1.fc21.noarch, python-libs-2.7.7-2.fc21.x86_64
package:        anaconda-core-21.48.1-1.fc21.x86_64
packaging.log:  
product:        Fedora
reason:         FormatCreateError: ('invalid device specification', '/dev/sda2')
release:        Fedora release 21 (Twenty One)
version:        21

Comment 17 patrick korsnick 2014-08-12 01:10:23 UTC
Another user experienced a similar problem:

tried to install fedora 21 prerelease xfce t2 from a usb stick onto a hp zbook 17 in uefi mode with secure boot enabled

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Xfce-x86_64-21-Alpha ro rd.live.image quiet rhgb rd.live.check
hashmarkername: anaconda
kernel:         3.16.0-0.rc5.git1.1.fc21.x86_64
other involved packages: python-blivet-0.61-1.fc21.noarch, python-libs-2.7.7-2.fc21.x86_64
package:        anaconda-core-21.48-1.fc21.x86_64
packaging.log:  
product:        Fedora
reason:         FormatCreateError: ('invalid device specification', '/dev/sda2')
release:        Fedora release 21 (Twenty One)
version:        21

Comment 18 Chris Murphy 2014-08-12 01:22:26 UTC
Sorry. I suggested you trie it but things are a bit messy right now in pre-release land! This is probably a duplicate of bug 1109244, per comment 22:

1. Restart the live media, and edit the GRUB boot entry (use e), add the following as a kernel parameter:
updates=http://dlehman.fedorapeople.org/updates/updates-1109244.1.img

2. *before* launching the installer:

# dnf upgrade anaconda python-blivet

That should get you python-blivet-0.61-1.fc21 and anaconda-21.48.2-1.fc21. When you launch the installer, the updates image will automatically be applied and you should be able to proceed with an installation. Please confirm in this bug if it works and I'll mark it as a duplicate.

Comment 19 patrick korsnick 2014-08-12 03:59:59 UTC
(In reply to Chris Murphy from comment #18)
> Sorry. I suggested you trie it but things are a bit messy right now in
> pre-release land! This is probably a duplicate of bug 1109244, per comment
> 22:
> 
> 1. Restart the live media, and edit the GRUB boot entry (use e), add the
> following as a kernel parameter:
> updates=http://dlehman.fedorapeople.org/updates/updates-1109244.1.img
> 
> 2. *before* launching the installer:
> 
> # dnf upgrade anaconda python-blivet
> 
> That should get you python-blivet-0.61-1.fc21 and anaconda-21.48.2-1.fc21.
> When you launch the installer, the updates image will automatically be
> applied and you should be able to proceed with an installation. Please
> confirm in this bug if it works and I'll mark it as a duplicate.

Hi Chris,

That procedure worked. I already had python-blivet-0.61-1.fc21 on bootup but the dnf command upgraded anaconda and I was able to complete the install. I did get a message along the way that the system wouldn't be bootable and was presented a choice to continue or not.

After the reboot I got the familiar grub menu, but it failed to boot because of Secure Boot. Disabling SB allowed it to boot up!

Thanks for the help!

Comment 20 Chris Murphy 2014-08-13 02:36:51 UTC
(In reply to patrick korsnick from comment #19)
> After the reboot I got the familiar grub menu, but it failed to boot >because of Secure Boot. Disabling SB allowed it to boot up!

This needs a new bug so it can hopefully get fixed. If it happens prior to GRUB menu with a message "Secure boot failed" then file against component shim. If you get a GRUB menu list of kernels you can choose, and the message occurs after that, then file the bug against the kernel with text of the failure message, or a cell phone photo attached.

Comment 21 Mark Hamzy 2014-09-10 15:03:32 UTC
Another user experienced a similar problem:

Installed using entire disk after reclaiming over an existing installation.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/ppc/ppc64/vmlinuz inst.vnc inst.sshd ip=9.5.178.25::9.5.178.1:255.255.255.0:ppc64lehamzytest2.rch.stglabs.ibm.com:eth0:none nameserver=9.5.175.8 bootdev=eth0
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.ppc64le
package:        anaconda-21.48.3-1
product:        Fedora-Server
reason:         FormatCreateError: ('invalid device specification', '/dev/sda2')
release:        Cannot get release name.
version:        21

Comment 22 satellitgo 2014-09-18 14:04:24 UTC
Another user experienced a similar problem:

liveinst install of MATE-Compiz  koji latest f21 Reelease Canidate to HD

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE_Compiz-x86_64-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.x86_64
other involved packages: python-libs-2.7.8-4.1.fc21.x86_64, python-blivet-0.61.2-2.fc21.noarch
package:        anaconda-core-21.48.7-1.fc21.x86_64
packaging.log:  
product:        Fedora
reason:         FormatCreateError: ('invalid device specification', '/dev/sdb1')
release:        Fedora release 21 (Twenty One)
version:        21

Comment 23 Mark Hamzy 2014-09-25 18:20:13 UTC
Another user experienced a similar problem:

Select three disks. Automatically install LVM on them.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/ppc/ppc64/vmlinuz inst.vnc inst.sshd ip=9.5.178.25::9.5.178.1:255.255.255.0:ppc64lehamzytest2.rch.stglabs.ibm.com:eth0:none nameserver=9.5.175.8 bootdev=eth0
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.ppc64le
package:        anaconda-21.48.6-1
product:        Fedora-Server
reason:         FormatCreateError: ('invalid device specification', '/dev/sda2')
release:        Cannot get release name.
version:        21_Alpha_TC3

Comment 24 satellitgo 2014-10-05 08:04:28 UTC
Another user experienced a similar problem:

try to install LXDE with only wireless network on live

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-LXDE-x86_64-21_Beta- rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.16.3-302.fc21.x86_64
other involved packages: python-libs-2.7.8-4.1.fc21.x86_64, python-blivet-0.62-1.fc21.noarch
package:        anaconda-core-21.48.7-1.fc21.x86_64
packaging.log:  
product:        Fedora"
reason:         FormatCreateError: ('invalid device specification', '/dev/sdb1')
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 25 David Shea 2014-10-07 21:05:33 UTC

*** This bug has been marked as a duplicate of bug 1109244 ***


Note You need to log in before you can comment on or make changes to this bug.