Bug 1120932 - After resize and chkdsk, ntfsresize always reports "Volume is scheduled for check"
Summary: After resize and chkdsk, ntfsresize always reports "Volume is scheduled for c...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ntfsprogs
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 02:28 UTC by Chris Murphy
Modified: 2014-07-18 04:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 04:38:40 UTC


Attachments (Terms of Use)
strace ntfsresize -m (10.09 KB, text/plain)
2014-07-18 02:30 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2014-07-18 02:28:49 UTC
Description of problem: A Windows 8.1 NTFS volume is successfully resized. However, ntfsresize -m reports that the volume is scheduled for check, and to run chkdsk /f, even though this has already been done with no problems found.


Version-Release number of selected component (if applicable):
ntfsprogs-2014.2.15-3.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install Windows 8.1
2. Install Fedora 21, resizing Windows volume by 50%, complete installation.
3. Reboot Windows succeeds, no errors.
4. ntfsresize -m

Actual results:
[root@localhost ~]# ntfsresize -m /dev/sda2
ntfsresize v2014.2.15 (libntfs-3g)
ERROR: Volume is scheduled for check.
Run chkdsk /f and please try again, or see option -f.


Expected results:

Not this.


Additional info:

If I run chkdsk, or chkdsk /f on the volume from Windows 8.1, this same message for ntfsresize -m occurs.

The installer log ran ntfsresize -m before resizing, and the command returned a minimum size for the volume, not this message. So the problem is that once resized, even though chkdsk is run, th emessage appears to be persistent.

Comment 1 Chris Murphy 2014-07-18 02:30:06 UTC
Created attachment 918932 [details]
strace ntfsresize -m

Comment 2 Chris Murphy 2014-07-18 04:38:40 UTC
OK nevermind, chkdsk C: was fixing the small 350mb system partition, not the main partition. chkdsk D: /f did fix somethings and cleared whatever flag ntfsresize set; I no longer get the reported error message.

Odd though that Windows 8.1 appears to ignore this flag, does not run a chkdsk at startup. Whereas Windows 7 does.


Note You need to log in before you can comment on or make changes to this bug.