Bug 1120960 - Unable to download topics from a search
Summary: Unable to download topics from a search
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: PressGang CCMS
Classification: Community
Component: Web-UI
Version: 1.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.9
Assignee: Lee Newson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 04:09 UTC by Lee Newson
Modified: 2014-09-01 01:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 01:20:38 UTC


Attachments (Terms of Use)

Description Lee Newson 2014-07-18 04:09:10 UTC
Attempting to click the "Download ZIP" button on the search screen throws the following error:

Exception: Exception caught: Must call edit() first

This is caused by a missed check for changes performed in 1.8 to fix script timeouts in FF24.

Workaround: Click the "Tags" tab before clicking "Download ZIP"

Comment 1 Lee Newson 2014-07-18 04:11:14 UTC
Fixed in 1.9-SNAPSHOT build 201407181407

The download handler now includes the hasTagsBeenInitialised() check, before attempting to flush the tags editor.

Note: This version is currently live on the test/development server.

Comment 2 Matthew Casperson 2014-07-23 20:30:02 UTC
Tested downloading the zip and cvs directly from the field search screen, after selecting some tags, and after loading a search. All worked ok.

Comment 3 Matthew Casperson 2014-07-23 20:34:11 UTC
My mistake - loading a filter and then using the download zip or csv buttons results in all topics being downloaded. It seems like the tags are not included in the query until the tags tab has been clicked.

To replicate, load a saved search filter and then click "Download Topic ZIP". You'll get all topics.

If you then click the tags tab and click "Download Topic ZIP", you'll get the expected results.

Comment 4 Lee Newson 2014-07-23 23:44:14 UTC
Fixed in 1.9-SNAPSHOT build 201407240939

Clicking the "Load" filter button will now load the search tags as well (assuming the filter has tags), which means that it can then be used when downloading the zip or searching.

Note: You may get the script timeouts in FF24 or lower, however that has to do with BZ#1116739.

Comment 5 Lee Newson 2014-07-24 01:07:26 UTC
This version has been deployed to the test/development server.


Note You need to log in before you can comment on or make changes to this bug.