Bug 1120984 - [pt_BR][es_ES][ja_JP][de_DE][RHEVM3.5][Admin Portal] - Check boxes overlapping with the corresponding levels New Logical Network page
Summary: [pt_BR][es_ES][ja_JP][de_DE][RHEVM3.5][Admin Portal] - Check boxes overlappin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: 3.5.0
Assignee: Lior Vernia
QA Contact: Yuko Katabami
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 05:33 UTC by Satyabrata Maitra
Modified: 2016-02-10 19:58 UTC (History)
13 users (show)

Fixed In Version: vt2.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:06:50 UTC
oVirt Team: Network


Attachments (Terms of Use)
Create New Logical Networks overlapping issue (47.40 KB, image/png)
2014-07-18 05:33 UTC, Satyabrata Maitra
no flags Details
2nd issue with Manage Network described in Addi. Info section. (46.35 KB, image/png)
2014-07-18 05:34 UTC, Satyabrata Maitra
no flags Details
ja_JP network>cluster>manage network issue (84.31 KB, image/png)
2014-07-22 06:29 UTC, Bhushan Barve
no flags Details
de_DE network>cluster>manage network issue (81.47 KB, image/png)
2014-07-22 06:31 UTC, Bhushan Barve
no flags Details
ja_JP network>new>cluster tab (91.42 KB, image/png)
2014-07-22 06:33 UTC, Bhushan Barve
no flags Details
de_DE network>new>cluster tab (45.85 KB, image/png)
2014-07-22 06:35 UTC, Bhushan Barve
no flags Details
Network Fixed (55.84 KB, image/png)
2014-10-14 07:44 UTC, Lijun Li
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31613 master MERGED webadmin: Add some spacing to checkbox cell labels Never
oVirt gerrit 31694 ovirt-engine-3.5 MERGED webadmin: Add some spacing to checkbox cell labels Never

Description Satyabrata Maitra 2014-07-18 05:33:24 UTC
Created attachment 918969 [details]
Create New Logical Networks overlapping issue

Description of problem:
Go to Networks --> Click on "New" (to create a new logical network) --> Click on Cluster tab.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager: 3.5.0-0.4.master.el6_5

How reproducible:
Always

Steps to Reproduce:
1. Please follow the steps described in the Description Section
2.
3.

Actual results:
"Attach All" and "Required All" Check boxes are overlapping with the corresponding text or level

Expected results:
Both should be clearly separated with a better UI design.

Additional info:

Another similar Scenario :

There are couple of more of such kind of issues where the check boxes are overlapping with the levels or texts, such as :

Go to Networks tab --> Select any existing network --> Cluster Sub tab --> Manage Network.

Observe the "Assign All" and "Required All" Check boxes and corresponding texts/levels. These are overlapped as well.


Both the screen shot attached.

Comment 1 Satyabrata Maitra 2014-07-18 05:34:33 UTC
Created attachment 918970 [details]
2nd issue with Manage Network described in Addi. Info section.

Comment 2 Satyabrata Maitra 2014-07-18 09:12:47 UTC
Same observed for es_ES (Spanish)locale as well.

Comment 4 Bhushan Barve 2014-07-22 06:29:50 UTC
Created attachment 919806 [details]
ja_JP network>cluster>manage network issue

Comment 5 Bhushan Barve 2014-07-22 06:31:23 UTC
Created attachment 919807 [details]
de_DE network>cluster>manage network issue

Comment 6 Bhushan Barve 2014-07-22 06:33:33 UTC
Created attachment 919808 [details]
ja_JP network>new>cluster tab

Comment 7 Bhushan Barve 2014-07-22 06:35:52 UTC
Created attachment 919809 [details]
de_DE network>new>cluster tab

Comment 8 Lior Vernia 2014-08-18 13:22:58 UTC
This looks like yet another regression due to the Look & Feel patches.

What browser are you using? On Firefox 22 and 24 I don't see any overlap (though things do look like they're tighter together than in 3.4, so I'll send a fix).

Comment 10 Satyabrata Maitra 2014-08-19 04:28:39 UTC
I have tested it in various versions of firefox like 17.0.10, 24.5.0, 29.0 etc. What I observed that in which ever version it shows Caution message " This Browser version isn't optimal for displaying.......", there the overlapping gets visible more. 

Anyway, you are correct, they are little tighter together. It would look better if they maintains a minimum gap.

Few test Observations : 

OS        Firefox version           Overlapping

RHEL6.5   17.0.10                    No
RHEL6.6   24.7.0                     Yes
RHEL7.0   24.5.0                     Yes
Fedora19  29.0                       Yes

Comment 12 Lijun Li 2014-10-14 07:43:55 UTC
Verified it's fixed on the latest vt build: rhevm-3.5.0-0.14.beta.el6ev.noarch.rpm

Please see the attached screen-shot.

Comment 13 Lijun Li 2014-10-14 07:44:24 UTC
Created attachment 946716 [details]
Network Fixed

Comment 14 Eyal Edri 2015-02-17 17:06:50 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.