Bug 1120985 - User should not be allowed to create OS with same name and version
Summary: User should not be allowed to create OS with same name and version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 05:42 UTC by Sachin Ghai
Modified: 2019-08-15 03:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:42:26 UTC


Attachments (Terms of Use)
two enteries with same OS name and version (25.72 KB, image/png)
2014-07-18 05:42 UTC, Sachin Ghai
no flags Details
UI raises error on creating an OS with existing name and version (55.54 KB, image/png)
2015-09-01 12:44 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2014-07-18 05:42:03 UTC
Created attachment 918971 [details]
two enteries with same OS name and version

Description of problem:
I was trying to create OS with name RedHat and version 6.5. Later, I realized OS was already there with same name and version. I think UI should throw some error message that "OS Name with same version has already been taken"

I think we can't uniqueify OS just on the basis of name. As OS can be of same name but with diff versions.

Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. create a OS with name RedHat and major/minor version: 6/5
2. create another OS with same name and version.
3.

Actual results:
UI allows use to create OS with same name and version

Expected results:
UI should throw error if one OS already there with same name and version

Additional info:

Comment 2 Dominic Cleal 2014-08-01 14:15:48 UTC
Created redmine issue http://projects.theforeman.org/issues/6886 from this bug

Comment 3 Bryan Kearney 2015-04-28 18:02:47 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7743 has been closed
-------------
Joseph Magen
There was a recent commit 8b737c9c7648b3726dadb3b2e4708fcb43af02a8 that fixed this.

It was unfortunately hidden within a commit called 'fixes #4386 - gem friendly_id to simplify find by id, name, label, etc'

The was a db migration that added a field called 'title' that must be unique.

Please verify that this is fixed and I (or you) can close this issue.
-------------
Shlomi Zadok
Applied in changeset commit:59b230959ab24b3573eb87616805bf3218a2cb13.

Comment 4 Sachin Ghai 2015-09-01 12:43:30 UTC
Verified with upstream:

foreman-proxy-1.10.0-0.develop.201508250705gitb446e0c.el6.noarch
rubygem-smart_proxy_discovery-1.0.2-1.el6.noarch
foreman-1.10.0-0.develop.201508241946git8658fa3.el6.noarch
foreman-release-1.10.0-0.develop.201508241946git8658fa3.el6.noarch
ruby193-rubygem-hammer_cli_import-0.10.21-3.el6.noarch
ruby193-rubygem-hammer_cli_foreman_docker-0.0.3-3.el6.noarch
ruby193-rubygem-hammer_cli-0.3.0-1.201508241209git174f507.el6.noarch
ruby193-rubygem-hammer_cli_foreman_tasks-0.0.7-2.el6.noarch
ruby193-rubygem-hammer_cli_foreman_bootdisk-0.1.3-2.el6.noarch
ruby193-rubygem-hammer_cli_katello-0.0.17-1.el6.noarch

On creating a OS with existing name and version, UI raises:

"Operating system version already exists"

Please see the attached screenshot

Comment 5 Sachin Ghai 2015-09-01 12:44:26 UTC
Created attachment 1068997 [details]
UI raises error on creating an OS with existing name and version

Comment 8 errata-xmlrpc 2016-07-27 08:42:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.