Bug 1121008 - kickstart rhel7 with source nfs with opts fails
Summary: kickstart rhel7 with source nfs with opts fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: David Shea
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 06:53 UTC by Christophe Augello
Modified: 2019-04-16 14:14 UTC (History)
3 users (show)

Fixed In Version: anaconda-19.31.83-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 14:02:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0312 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2015-03-05 17:35:22 UTC
Red Hat Knowledge Base (Solution) 1344563 None None None Never

Description Christophe Augello 2014-07-18 06:53:26 UTC
Description of problem:
kickstart installation of rhel7 with source as nfs with options fails

Version-Release number of selected component (if applicable):


How reproducible:
kickstart a rhel 7 installation

Steps to Reproduce:
1. Set source as :
nfs --server=10.242.225.164 --dir=/ks/rhel-7/ISO/image --opts="ro"

Actual results:

12:36:34,148 INFO program: Running... mount -t nfs -o 10.242.225.164,nolock /ks/rhel-7/ISO/image:ro /mnt/install/source
12:36:34,572 INFO program: mount.nfs: Failed to resolve server /ks/rhel-7/ISO/image: Name or service not known

=> The mount command seems to be is upside down : 
"10.242.225.164,nolock"  => considered as options
/ks/rhel-7/ISO/image => considered as server
ro : considered as folder

Expected results:

noclock,ro => option
10.242.225.164 => server
/ks/rhel-7/ISO/image => folder

Additional info:

Comment 3 David Shea 2014-07-18 17:53:49 UTC
Fixed in upstream commit 8d04cfe13d11d9fc98e430060ea7dd809f70dd9e

Comment 5 Alexander Todorov 2014-11-24 14:13:10 UTC
Booted from boot.iso with a kickstart containing:

nfs --server=server.example.com --dir=/mnt/iso --opts="ro"


Installation completed. Moving to VERIFIED.

Comment 7 errata-xmlrpc 2015-03-05 14:02:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0312.html


Note You need to log in before you can comment on or make changes to this bug.