Bug 1121012 - UI should raise a success notification on adding/updating OS parameters
Summary: UI should raise a success notification on adding/updating OS parameters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 07:11 UTC by Sachin Ghai
Modified: 2019-04-01 20:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:42:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 6771 None None None 2016-04-22 16:42:51 UTC

Description Sachin Ghai 2014-07-18 07:11:01 UTC
Description of problem:
when we add/update OS parameters, then on submation the form gets closed and we don't know whether parameter is added or updated unless we navigate back to 'Parameters' tab.

So UI should raise a success notification saying "Successfully Updated os <name>"

Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. create an OS
2. Add/update OS parameter
3.

Actual results:
No success notification, no way to know whether parameter was added/updated unless we navigate back to 'parameters' tab

Expected results:
UI should raise a success notification when we update anything under OS

Additional info:

Comment 1 RHEL Product and Program Management 2014-07-18 07:13:47 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-07-24 15:01:31 UTC
Created redmine issue http://projects.theforeman.org/issues/6771 from this bug

Comment 4 Bryan Kearney 2015-01-19 11:02:42 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6771 has been closed

Comment 5 Sachin Ghai 2015-09-01 12:51:05 UTC
Verified with upstream:

foreman-proxy-1.10.0-0.develop.201508250705gitb446e0c.el6.noarch
rubygem-smart_proxy_discovery-1.0.2-1.el6.noarch
foreman-1.10.0-0.develop.201508241946git8658fa3.el6.noarch
foreman-release-1.10.0-0.develop.201508241946git8658fa3.el6.noarch
ruby193-rubygem-hammer_cli_import-0.10.21-3.el6.noarch
ruby193-rubygem-hammer_cli_foreman_docker-0.0.3-3.el6.noarch
ruby193-rubygem-hammer_cli-0.3.0-1.201508241209git174f507.el6.noarch
ruby193-rubygem-hammer_cli_foreman_tasks-0.0.7-2.el6.noarch
ruby193-rubygem-hammer_cli_foreman_bootdisk-0.1.3-2.el6.noarch
ruby193-rubygem-hammer_cli_katello-0.0.17-1.el6.noarch


I can't see notifications on UI while updating OS parameters.

Comment 6 Bryan Kearney 2015-09-01 14:01:06 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6771 has been closed

Comment 7 Ohad Levy 2015-09-02 10:59:51 UTC
can you read the upstream comment and verify that it actually failed?

Comment 9 Tazim Kolhar 2015-11-04 13:51:51 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***
Version Tested:
# rpm -qa | grep foreman
foreman-proxy-1.11.0-0.develop.201510201341git00875b3.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-debug-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-compute-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-gce-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-vmware-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-ovirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-release-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-libvirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510201150gitab068d9.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch

steps:
1. create an OS
2. Add/update OS parameter

UI raises a success notification when we update anything under OS

Comment 12 errata-xmlrpc 2016-07-27 08:42:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.