Bug 1121019 - Default configuration does not specify WSGISocketPrefix
Summary: Default configuration does not specify WSGISocketPrefix
Keywords:
Status: CLOSED DUPLICATE of bug 966311
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mod_wsgi
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Web Stack Team
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 07:50 UTC by Ian Wienand
Modified: 2014-10-21 10:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-21 10:54:42 UTC


Attachments (Terms of Use)

Description Ian Wienand 2014-07-18 07:50:21 UTC
Description of problem:

The default does not specify the path, so httpd puts the socket in /etc/httpd/logs which can not be accessed.

See [1] for an example of this failure.

I found bug#611182 which is old and for Fedora.  It seems to be fixed there.

Versions I am using

---
httpd              x86_64      2.2.15-30.el6_5      rhel-internal-z      820 k
mod_wsgi           x86_64      3.2-6.el6_5          rhel-internal-z       65 k
---

[1] https://review.openstack.org/#/c/107623/

Comment 2 Joe Orton 2014-09-10 10:29:26 UTC
This is essentially the same route-cause as bug 966311, we need to fix the mod_wsgi compile-time default to use run/ not logs/, so it works by default - as we did in Fedora.  Marking as dupe.


Note You need to log in before you can comment on or make changes to this bug.