Bug 1121048 - Many RestClient::InternalServerError when trying to work with repositories
Summary: Many RestClient::InternalServerError when trying to work with repositories
Keywords:
Status: CLOSED DUPLICATE of bug 1117410
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 09:18 UTC by jakub.sliva
Modified: 2014-08-12 21:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 21:14:28 UTC


Attachments (Terms of Use)
production.log (211.80 KB, text/plain)
2014-07-18 09:18 UTC, jakub.sliva
no flags Details

Description jakub.sliva 2014-07-18 09:18:43 UTC
Created attachment 919003 [details]
production.log

Description of problem:
There are many Internal Server Errors 500 in production.log when trying to work with repositories in Satellite 6 beta. For example, when trying to create a repository, when trying to get to the Sync Status section or Product section in WebUI.

Version-Release number of selected component (if applicable):
Name        : katello
Version     : 1.5.0
Release     : 26.el6sat
From repo   : rhel-server-6-satellite-6-beta-rpms


How reproducible:
everytime

Steps to Reproduce:
1) WebUI -> Create product -> Create repository
2) WebUI -> Sync status

Actual results:
It is not possible to work with repositories. Clicking on Products results in displaying "Loading..." and nothing happens. Clicking on Sync status -> "We're sorry, but something went wrong." Production log is attached.

Expected results:
Creation and synchronization of repositories should work.

Additional info:
Server is behind a proxy. Proxy was set during installation:
katello-installer -v --katello-proxy-url=http://proxy.company.com --katello-proxy-port=81

Comment 1 RHEL Product and Program Management 2014-07-18 09:44:04 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Mike McCune 2014-08-12 21:14:28 UTC
This is most likely caused by:

https://bugzilla.redhat.com/show_bug.cgi?id=1117410

this is resolved in the upcoming release

See the workaround listed here:

https://bugzilla.redhat.com/show_bug.cgi?id=1117410#c1

If you feel this isn't a duplicate feel free to re-open and we can investigate further.

*** This bug has been marked as a duplicate of bug 1117410 ***


Note You need to log in before you can comment on or make changes to this bug.