Bug 1121062 - nfs-ganesha dumps core on running pynfs tests OPDG10 , OPDG11
Summary: nfs-ganesha dumps core on running pynfs tests OPDG10 , OPDG11
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Meghana
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 09:44 UTC by Meghana
Modified: 2015-09-01 02:54 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Meghana 2014-07-18 09:44:45 UTC
Description of problem:
nfs-ganesha dumps core when pynfs tests OPDG10 and OPDG11 tests of the pynfs test suite is run. These two tests were known failures prior to nfs-ganesha
v2.2_dev1 branch. These tests now result in a crash.


Version-Release number of selected component (if applicable):
nfs-ganesha v2.2_dev1


How reproducible:
Always

Steps to Reproduce:
1.Export a GlusterFS volume via nfs-ganesha
2.Perform a nfsv4 mount of this volume on a client.
3.Run the tests OPDG10 and OPDG11 from the pynfs test suite.

Actual results:
nfs-ganesha crashes.

Expected results:
The test should fail as it is one of the known failures. 

Additional info:

Comment 1 Anand Avati 2014-07-18 10:20:55 UTC
REVIEW: http://review.gluster.org/8333 (nfs-ganesha dumps core when Pynfs tests OPDG1O and OPDG11 are run.) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 2 Anand Avati 2014-07-18 11:19:41 UTC
REVIEW: http://review.gluster.org/8333 (nfs-ganesha dumps core when Pynfs tests OPDG1O and OPDG11 are run.) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 3 Anand Avati 2014-07-21 05:50:33 UTC
REVIEW: http://review.gluster.org/8333 (nfs-ganesha dumps core when Pynfs tests OPDG1O and OPDG11 are run.) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 4 Anand Avati 2014-07-21 08:22:17 UTC
REVIEW: http://review.gluster.org/8333 (nfs-ganesha dumps core when Pynfs tests OPDG1O and OPDG11 are run.) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 5 Anand Avati 2014-07-21 11:43:45 UTC
REVIEW: http://review.gluster.org/8333 (nfs-ganesha dumps core when Pynfs tests OPDG1O and OPDG11 are run.) posted (#5) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 6 Anand Avati 2014-07-25 05:05:39 UTC
REVIEW: http://review.gluster.org/8333 (nfs-ganesha dumps core when Pynfs tests OPDG1O and OPDG11 are run.) posted (#6) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 7 Anand Avati 2014-07-30 11:16:10 UTC
REVIEW: http://review.gluster.org/8333 (nfs-ganesha  dumps core when Pynfs tests OPDG1O and OPDG11 are run.) posted (#7) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 8 Anand Avati 2014-08-02 06:30:24 UTC
COMMIT: http://review.gluster.org/8333 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 41e2384181e854c06d3a234c2f37aacf9d92f53c
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Tue Jul 29 20:20:13 2014 +0530

    nfs-ganesha  dumps core when Pynfs tests OPDG1O and OPDG11 are run.
    
    Assgining -1 to ret if fd_create fails. The tests somehow
    enter an error case 'if' block (this will be a separate bug fix),
    before glfd is created. Need an addiitional check to see
    if glfd exists before entering the 'else' block in 'out'.
    
    glfs_h_creat was missing a similar check, adding that in
    this bug fix.)
    
    Change-Id: I3b69540c53e8169538848b9e7f23ffc8ef0ac189
    BUG: 1121062
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/8333
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 9 Niels de Vos 2015-05-14 17:26:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:35:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:37:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 12 Niels de Vos 2015-05-14 17:42:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.