Bug 1121096 - Content Source setting on host group is not inherited when provisioning hosts.
Summary: Content Source setting on host group is not inherited when provisioning hosts.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: All
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1139277
TreeView+ depends on / blocked
 
Reported: 2014-07-18 10:49 UTC by Rich Jerrido
Modified: 2018-12-09 18:11 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, content source settings on a host group were not inherited when provisioning hosts because of an error in the implementation of host group content source inheritance. This implementation has been corrected and hosts can now inherit their hostgroup's content source.
Clone Of:
Environment:
Last Closed: 2014-11-13 22:28:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1857 normal SHIPPED_LIVE Red Hat Satellite 6 server bug fix update 2014-11-14 03:28:23 UTC

Description Rich Jerrido 2014-07-18 10:49:22 UTC
Description of problem:

When configuring a host group, one can set the 'content source' parameter, which controls the capsule which will be sourced for installation and updates. If this parameter is set on a host group, the parameter is not inherited when creating a new host and associating it with the same host group. 


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a host group. 
2. Set the content source to the hostname of a capsule
3. Fill in the other required paramaters for the host-group.
4. Click Submit
5. Create New Host
6. Under 'Host Group' select the previously created host group. 

Actual results:

'Content Source' value isn't inherited. 

Expected results:

'Content Source' value is inherited, same as other values set on the host group.

Comment 1 RHEL Product and Program Management 2014-07-18 11:13:44 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 jmagen@redhat.com 2014-07-24 16:08:58 UTC
http://projects.theforeman.org/issues/6773

Comment 4 Bryan Kearney 2014-08-12 08:03:59 UTC
Upstream bug assigned to dlobatog@redhat.com

Comment 5 Bryan Kearney 2014-09-15 13:44:12 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6773 has been closed
-------------
Daniel Lobato Garcia
Applied in changeset commit:katello|fe207f49ea7c7ce5b0b52c6d1f3a06b90fca35b7.

Comment 10 sthirugn@redhat.com 2014-10-10 21:00:39 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***

Content source of the host is now pre-populated from the host group.

Version Tested:
Nightly Oct 10, 2014
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.32-1.el6.noarch
* candlepin-common-1.0.8-1.el6.noarch
* candlepin-selinux-0.9.32-1.el6.noarch
* candlepin-tomcat6-0.9.32-1.el6.noarch
* elasticsearch-0.90.10-7.el6.noarch
* foreman-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-compute-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-gce-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-libvirt-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-ovirt-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-postgresql-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-proxy-1.7.0-0.develop.201410081229git52f0bac.el6.noarch
* foreman-release-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* foreman-selinux-1.7.0-0.develop.201409301113git2f345de.el6.noarch
* foreman-vmware-1.7.0-0.develop.201410091913git35b6fb9.el6.noarch
* katello-2.1.0-1.201410091751gitc9c45c1.el6.noarch
* katello-certs-tools-2.0.1-1.el6.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-2.1.0-1.201410021645git304e036.el6.noarch
* katello-repos-2.1.1-1.el6.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-docker-plugins-0.2.1-0.2.beta.el6.noarch
* pulp-katello-0.3-3.el6.noarch
* pulp-nodes-common-2.5.0-0.7.beta.el6.noarch
* pulp-nodes-parent-2.5.0-0.7.beta.el6.noarch
* pulp-puppet-plugins-2.5.0-0.7.beta.el6.noarch
* pulp-puppet-tools-2.5.0-0.7.beta.el6.noarch
* pulp-rpm-plugins-2.5.0-0.7.beta.el6.noarch
* pulp-selinux-2.5.0-0.7.beta.el6.noarch
* pulp-server-2.5.0-0.7.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.3.1-1.el6.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6.noarch
* ruby193-rubygem-runcible-1.2.0-1.el6.noarch

Comment 11 sthirugn@redhat.com 2014-11-04 22:14:15 UTC
Failed in z-stream build since the code is not cherrypicked.  This happened because the bug was moved to VERIFIED before z-stream was built.  Moving back to POST.

Version Tested:
Satellite-6.0.4-RHEL-6-20141029.5

Comment 14 Kedar Bidarkar 2014-11-11 13:52:11 UTC
VERIFIED with RHEL6-Sat6 Satellite 6.0.6 Compose2


Installed Packages

    candlepin-0.9.23.1-1.el6.noarch
    candlepin-common-1.0.1-1.el6_5.noarch
    candlepin-scl-1-5.el6_4.noarch
    candlepin-scl-quartz-2.1.5-5.el6_4.noarch
    candlepin-scl-rhino-1.7R3-1.el6_4.noarch
    candlepin-scl-runtime-1-5.el6_4.noarch
    candlepin-selinux-0.9.23.1-1.el6.noarch
    candlepin-tomcat6-0.9.23.1-1.el6.noarch
    elasticsearch-0.90.10-6.el6sat.noarch
    katello-1.5.0-30.el6sat.noarch
    katello-certs-tools-1.5.6-1.el6sat.noarch
    katello-default-ca-1.0-1.noarch
    katello-installer-0.0.64-1.el6sat.noarch
    katello-server-ca-1.0-1.noarch
    mod_wsgi-3.4-1.pulp.el6sat.x86_64
    pulp-katello-0.3-4.el6sat.noarch
    pulp-nodes-common-2.4.3-0.1.beta.el6sat.noarch
    pulp-nodes-parent-2.4.3-0.1.beta.el6sat.noarch
    pulp-puppet-plugins-2.4.3-1.el6sat.noarch
    pulp-puppet-tools-2.4.3-1.el6sat.noarch
    pulp-rpm-plugins-2.4.3-1.el6sat.noarch
    pulp-selinux-2.4.3-1.el6sat.noarch
    pulp-server-2.4.3-1.el6sat.noarch
    python-gofer-qpid-1.3.0-1.el6sat.noarch
    python-isodate-0.5.0-1.pulp.el6sat.noarch
    python-kombu-3.0.15-12.pulp.el6sat.noarch
    python-pulp-bindings-2.4.3-1.el6sat.noarch
    python-pulp-common-2.4.3-1.el6sat.noarch
    python-pulp-puppet-common-2.4.3-1.el6sat.noarch
    python-pulp-rpm-common-2.4.3-1.el6sat.noarch
    python-qpid-0.22-14.el6sat.noarch
    python-qpid-qmf-0.22-37.el6.x86_64
    qpid-cpp-client-0.22-42.el6.x86_64
    qpid-cpp-server-0.22-42.el6.x86_64
    qpid-cpp-server-linearstore-0.22-42.el6.x86_64
    qpid-java-client-0.22-6.el6.noarch
    qpid-java-common-0.22-6.el6.noarch
    qpid-proton-c-0.7-1.el6.x86_64
    qpid-qmf-0.22-37.el6.x86_64
    qpid-tools-0.22-12.el6.noarch
    ruby193-rubygem-katello-1.5.0-93.el6sat.noarch
    rubygem-hammer_cli_katello-0.0.4-14.el6sat.noarch
    rubygem-smart_proxy_pulp-1.0.1-1.1.el6sat.noarch

Comment 15 Kedar Bidarkar 2014-11-11 13:53:54 UTC
The content source setting on host group is now getting inherited when provisioning hosts.

Comment 16 Kedar Bidarkar 2014-11-12 12:24:44 UTC
VERIFIED for RHEL7 sat6 with build Satellite-6.0.4-RHEL-7-20141107.0


Installed Packages

    candlepin-0.9.23.1-1.el7.noarch
    candlepin-common-1.0.1-1.el7.noarch
    candlepin-guice-3.0-2_redhat_1.el7.noarch
    candlepin-scl-1-5.el7.noarch
    candlepin-scl-quartz-2.1.5-6.el7.noarch
    candlepin-scl-rhino-1.7R3-3.el7.noarch
    candlepin-scl-runtime-1-5.el7.noarch
    candlepin-selinux-0.9.23.1-1.el7.noarch
    candlepin-tomcat-0.9.23.1-1.el7.noarch
    elasticsearch-0.90.10-6.el7sat.noarch
    katello-1.5.0-30.el7sat.noarch
    katello-certs-tools-1.5.6-1.el7sat.noarch
    katello-default-ca-1.0-1.noarch
    katello-installer-0.0.64-1.el7sat.noarch
    katello-server-ca-1.0-1.noarch
    pulp-katello-0.3-4.el7sat.noarch
    pulp-nodes-common-2.4.3-0.1.beta.el7sat.noarch
    pulp-nodes-parent-2.4.3-0.1.beta.el7sat.noarch
    pulp-puppet-plugins-2.4.3-1.el7sat.noarch
    pulp-puppet-tools-2.4.3-1.el7sat.noarch
    pulp-rpm-plugins-2.4.3-1.el7sat.noarch
    pulp-selinux-2.4.3-1.el7sat.noarch
    pulp-server-2.4.3-1.el7sat.noarch
    python-gofer-qpid-1.3.0-1.el7sat.noarch
    python-isodate-0.5.0-1.pulp.el7sat.noarch
    python-kombu-3.0.15-12.pulp.el7sat.noarch
    python-pulp-bindings-2.4.3-1.el7sat.noarch
    python-pulp-common-2.4.3-1.el7sat.noarch
    python-pulp-puppet-common-2.4.3-1.el7sat.noarch
    python-pulp-rpm-common-2.4.3-1.el7sat.noarch
    python-qpid-0.22-15.el7.noarch
    python-qpid-qmf-0.22-37.el7.x86_64
    qpid-cpp-client-0.22-42.el7.x86_64
    qpid-cpp-server-0.22-42.el7.x86_64
    qpid-cpp-server-linearstore-0.22-42.el7.x86_64
    qpid-java-client-0.22-7.el7.noarch
    qpid-java-common-0.22-7.el7.noarch
    qpid-proton-c-0.7-2.el7.x86_64
    qpid-qmf-0.22-37.el7.x86_64
    qpid-tools-0.22-13.el7.noarch
    ruby193-rubygem-katello-1.5.0-93.el7sat.noarch
    rubygem-hammer_cli_katello-0.0.4-14.el7sat.noarch
    rubygem-smart_proxy_pulp-1.0.1-1.1.el7sat.noarch

Comment 18 errata-xmlrpc 2014-11-13 22:28:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2014:1857


Note You need to log in before you can comment on or make changes to this bug.