Bug 1121105 - [origin_cartridge_229] App is not avaiable after install gmp for ruby-2.0 app
Summary: [origin_cartridge_229] App is not avaiable after install gmp for ruby-2.0 app
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
: ---
Assignee: Michal Fojtik
QA Contact: libra bugs
Depends On:
TreeView+ depends on / blocked
Reported: 2014-07-18 11:19 UTC by Yan Du
Modified: 2015-05-15 00:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-10-10 00:49:06 UTC

Attachments (Terms of Use)

Description Yan Du 2014-07-18 11:19:17 UTC
Description of problem:
App is not avaiable after install gmp for ruby-2.0 app

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
0. make sure your rails version >=4.0
1. Create a ruby-2.0 app name r20a
2. rails new r20a
3. Add gem 'gmp' in Gemfile
4. bundle check
5. bundle install
6. git push
7. Visit the app

Actual results:
step6: we could get the info like "remote: Installing rake (10.3.2) have installed according the log."

remote: Stopping Ruby cartridge
remote: Repairing links for 1 deployments
remote: Saving away previously bundled RubyGems
remote: Building git ref 'master', commit 5179e72
remote: Building Ruby cartridge
remote: Restoring previously bundled RubyGems
remote: NOTE: You can commit .openshift/markers/force_clean_build to force a clean bundle
remote: bundle install --deployment --path ./app-root/repo/vendor/bundle
remote: Fetching gem metadata from https://rubygems.org/.........
remote: Fetching gem metadata from https://rubygems.org/..
remote: Installing rake (10.3.2) 
remote: Installing i18n (0.6.11) 
remote: Installing json (1.8.1) 
remote: Installing minitest (5.4.0) 
remote: Installing thread_safe (0.3.4) 
remote: Installing tzinfo (1.2.1) 
remote: Installing activesupport (4.1.4) 
remote: Installing builder (3.2.2) 
remote: Installing erubis (2.7.0) 
remote: Installing actionview (4.1.4) 
remote: Installing rack (1.5.2) 
remote: Installing rack-test (0.6.2) 
remote: Installing actionpack (4.1.4) 
remote: Installing mime-types (1.25.1) 
remote: Installing polyglot (0.3.5) 
remote: Installing treetop (1.4.15) 
remote: Installing mail (2.5.4) 
remote: Installing actionmailer (4.1.4) 
remote: Installing activemodel (4.1.4) 
remote: Installing arel ( 
remote: Installing activerecord (4.1.4) 
remote: Installing coffee-script-source (1.7.1) 
remote: Installing execjs (2.2.1) 
remote: Installing coffee-script (2.3.0) 
remote: Installing thor (0.19.1) 
remote: Installing railties (4.1.4) 
remote: Installing coffee-rails (4.0.1) 
remote: Installing gmp (0.7.19) 
remote: Installing hike (1.2.3) 
remote: Installing multi_json (1.10.1) 
remote: Installing jbuilder (2.1.3) 
remote: Installing jquery-rails (3.1.1) 
remote: Using bundler (1.3.5) 
remote: Installing tilt (1.4.1) 
remote: Installing sprockets (2.11.0) 
remote: Installing sprockets-rails (2.1.3) 
remote: Installing rails (4.1.4) 
remote: Installing rdoc (4.1.1) 
remote: Installing sass (3.2.19) 
remote: Installing sass-rails (4.0.3) 
remote: Installing sdoc (0.4.0) 
remote: Installing spring (1.1.3) 
remote: Installing sqlite3 (1.3.9) 
remote: Installing turbolinks (2.2.2) 
remote: Installing uglifier (2.5.1) 
remote: Your bundle is complete!
remote: It was installed into ./vendor/bundle
remote: Post-install message from rdoc:
remote: Depending on your version of ruby, you may need to install ruby rdoc/ri data:
remote: <= 1.8.6 : unsupported
remote:  = 1.8.7 : gem install rdoc-data; rdoc-data --install
remote:  = 1.9.1 : gem install rdoc-data; rdoc-data --install
remote: >= 1.9.2 : nothing to do! Yay!
remote: Preparing build for deployment
remote: Deployment id is 2f9d8060
remote: Activating deployment
remote: I, [2014-07-18T10:45:59.813662 #31834]  INFO -- : Writing /var/lib/openshift/53c93094ee8c340fe80000d1/app-root/runtime/repo/public/assets/application-8300e97aaa7c4d0192301b7218164e7a.js
remote: I, [2014-07-18T10:45:59.892726 #31834]  INFO -- : Writing /var/lib/openshift/53c93094ee8c340fe80000d1/app-root/runtime/repo/public/assets/application-f4620e0ff93a2325f67e2da06f2f5791.css
remote: NOTE: To disable assets compilation use 'disable_asset_compilation' marker.
remote: Starting Ruby cartridge
remote: -------------------------
remote: Git Post-Receive Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://53c93094ee8c340fe80000d1@r20a-c.dev.rhcloud.com/~/git/r20a.git/
   615dccf..5179e72  master -> master


App is not available in web.

show below info :

You have already activated rake 0.9.6, but your Gemfile requires rake 10.3.2. Using bundle exec may solve this. (Gem::LoadError)
  /opt/rh/ror40/root/usr/share/gems/gems/bundler-1.3.5/lib/bundler/runtime.rb:33:in `block in setup'
  /opt/rh/ror40/root/usr/share/gems/gems/bundler-1.3.5/lib/bundler/runtime.rb:19:in `setup'
  /opt/rh/ror40/root/usr/share/gems/gems/bundler-1.3.5/lib/bundler.rb:120:in `setup'
  /opt/rh/ror40/root/usr/share/gems/gems/bundler-1.3.5/lib/bundler/setup.rb:17:in `<top (required)>'
  /opt/rh/ruby200/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:118:in `require'
  /opt/rh/ruby200/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:118:in `rescue in require'
  /opt/rh/ruby200/root/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:124:in `require'
  /opt/rh/ruby200/root/usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/loader_shared_helpers.rb:212:in `run_load_path_setup_code'
  /opt/rh/ruby200/root/usr/share/gems/gems/passenger-4.0.18/helper-scripts/rack-loader.rb:69:in `load_app'
  /opt/rh/ruby200/root/usr/share/gems/gems/passenger-4.0.18/helper-scripts/rack-loader.rb:96:in `<module:App>'
  /opt/rh/ruby200/root/usr/share/gems/gems/passenger-4.0.18/helper-scripts/rack-loader.rb:4:in `<module:PhusionPassenger>'
  /opt/rh/ruby200/root/usr/share/gems/gems/passenger-4.0.18/helper-scripts/rack-loader.rb:3:in `<main>'

Expected results:
should not get the error in step7, since the rake 10.3.2 already installed during git push.

Additional info:

Comment 1 Michal Fojtik 2014-07-18 12:19:56 UTC
For 'rails' you have to include this line in the Gemfile:

gem 'rake', '~> 0.9.6'

I'm still investigating this, because I saw this for the first time during working on the rails4-example. It might be something broken in the passenger.

Comment 3 Michal Fojtik 2014-07-23 13:20:22 UTC
QA: Reopening this bug as it should be now fixed on latest devenv to make sure it also works for you.

Comment 4 Yan Du 2014-07-24 07:17:32 UTC
Test on devenv_5003, issue could not be reproduced any more.

Move bug to verified. Thanks.

Note You need to log in before you can comment on or make changes to this bug.