Bug 1121121 - service foreman status returns non-zero when successful
Summary: service foreman status returns non-zero when successful
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 12:24 UTC by Lukas Pramuk
Modified: 2017-01-13 20:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 20:58:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7023 None None None 2016-04-22 16:41:56 UTC

Description Lukas Pramuk 2014-07-18 12:24:51 UTC
Description of problem:
service foreman status returns non-zero error code for success
It says "PASSED" but returns "1" 

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140711.0

How reproducible:
100%

Steps to Reproduce:
1. service foreman status
Foreman is running under passenger[PASSED]

2. echo $?
1

Actual results:
It says "PASSED" but returns "1" 

Expected results:
When it says "PASSED" it should return "0"

Comment 1 RHEL Product and Program Management 2014-07-18 12:43:55 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-08-11 16:32:37 UTC
The "1" is to indicate it can't even tell you what the status is, though LSB says this should actually be "4".  Zero would be even more misleading I think.

Comment 4 Dominic Cleal 2014-08-11 16:33:12 UTC
Created redmine issue http://projects.theforeman.org/issues/7023 from this bug

Comment 6 Lukas Pramuk 2015-02-17 15:26:00 UTC
If it can't even tell me the status why then it writes 'is running' ???

Comment 7 Bryan Kearney 2016-07-08 20:42:40 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 9 Bryan Kearney 2017-01-13 20:58:36 UTC
I do not envision this bug being addressed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.


Note You need to log in before you can comment on or make changes to this bug.