Bug 1121127 - vnet tx cksum offload broken under vlan
Summary: vnet tx cksum offload broken under vlan
Keywords:
Status: CLOSED DUPLICATE of bug 1132588
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.5
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Vlad Yasevich
QA Contact: Network QE
URL:
Whiteboard:
Depends On:
Blocks: 1131526
TreeView+ depends on / blocked
 
Reported: 2014-07-18 12:38 UTC by Jeremy Harris
Modified: 2018-12-09 18:11 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1131526 (view as bug list)
Environment:
Last Closed: 2014-08-25 15:24:04 UTC


Attachments (Terms of Use)

Description Jeremy Harris 2014-07-18 12:38:05 UTC
Description of problem:

  A VLAN'd vnet interface on a VM; host has bridge->bond->eth0/1.
TCP comms fail when the "eth1" interface in the VM has tx csum enabled (the
default), works with it disabled.  Reported under SIP on IPv6; replicated with
ssh on IPv4 and v6.   Comms target system has similar configuration.

First data-bearing transmitted packet from ssh client as captured on
bridge of host has bad cksum.  This might be expected if the offload
request is passed to the host with each packet, however disabling offload
on the bridge does not help (and commands on the client to enable offload
complete with no error).


Version-Release number of selected component (if applicable):
  kernel-2.6.32-431.5.1 (official)
  kernel-431.1.1 and -431.26.1 (self-built)


How reproducible:
  100%


Steps to Reproduce:
1. Networking config as above
2. ssh <target>
3.

Actual results:
  No password prompt


Expected results:
  Prompt for password


Additional info:

Comment 18 Vlad Yasevich 2014-08-18 23:41:26 UTC
It should actually be kernel.  Component updated.

Thanks.

Comment 21 Vlad Yasevich 2014-08-20 13:11:49 UTC
The proposed solution isn't complete.  Found additional issues related to this
functionality.  Trying to address.

Patch has been NACKed for rhel6.6. 

-vlad

Comment 22 Vlad Yasevich 2014-08-25 15:24:04 UTC
This problem is being resolved in a differnet way and for a different BZ.
This one can now be marked/closed as duplicate.

This problem was introduced by enabbling TSO/GSO offloading support for vlan devices on virtio-net.  The problem is really in the host kernel hw drivers where a lot of these drivers have VLAN hw acceleration enabled.  Thus, these host drivers make an assumption that any packet that needs TSO/GSO or checksum acceleration will not have a vlan header present.  This is not the case for packets now generated by virtual machines.

We are currently tracking different HW that has this issue in Bug 1132972.

As a workaround, you can disable checksum and TSO offloading on the vlan device.

-vlad

*** This bug has been marked as a duplicate of bug 1132588 ***


Note You need to log in before you can comment on or make changes to this bug.