Bug 1121128 - Fix collocating sets and ordered sets description
Summary: Fix collocating sets and ordered sets description
Keywords:
Status: CLOSED DUPLICATE of bug 1311749
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-High_Availability_Add-On_Reference
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Steven J. Levine
QA Contact: ecs-bugs
URL:
Whiteboard:
: 1129860 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 12:40 UTC by Tomas Jelinek
Modified: 2019-03-06 01:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-13 18:02:33 UTC


Attachments (Terms of Use)

Description Tomas Jelinek 2014-07-18 12:40:36 UTC
The documentation of 'Colocating Sets of Resources' is a little bit confusing leading users to improper use of pcs, see here: https://bugzilla.redhat.com/show_bug.cgi?id=1115608

I've already fixed the man page and pcs help. Please make the web documentation consistent with it.


6.3.3. Colocating Sets of Resources
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/High_Availability_Add-On_Reference/s1-colocationconstraints-HAAR.html#s2-unorderedresourcesets-HAAR
Please update the command syntax and options.
Here is the manpage version:
colocation set <resource1> <resource2> [resourceN]... [options] [set <resourceX> <resourceY> ... [options]] [setoptions [constraint_options]]
Create a colocation constraint with a resource set.
Available options are sequential=true/false, require-all=true/false, action=start/promote/demote/stop and role=Stopped/Started/Master/Slave.
Available constraint_options are score, score-attribute and score-attribute-mangle.


6.2.3. Ordered Resource Sets
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/High_Availability_Add-On_Reference/s1-orderconstraints-HAAR.html#s2-resourceorderlist-HAAR
Please update the command syntax and options.
Here is the manpage version:
order set <resource1> <resource2> [resourceN]... [options] [set <resourceX> <resourceY> ... [options]]
Create an ordered set of resources.
Available options are sequential=true/false, require-all=true/false, action=start/promote/demote/stop and role=Stopped/Started/Master/Slave.

Comment 3 Steven J. Levine 2014-11-18 22:20:00 UTC
*** Bug 1129860 has been marked as a duplicate of this bug. ***

Comment 6 Steven J. Levine 2015-05-05 19:49:22 UTC
Moving this back to ASSIGNED because I still think these sections could be improved with examples.

Comment 7 Steven J. Levine 2015-11-05 20:36:24 UTC
Moving to 7.3 in the hope that we'll have time to address this.

Comment 8 Steven J. Levine 2016-05-13 18:02:33 UTC

*** This bug has been marked as a duplicate of bug 1311749 ***


Note You need to log in before you can comment on or make changes to this bug.