Bug 1121130 - Disable the default libvirt network on compute nodes (virbr0)
Summary: Disable the default libvirt network on compute nodes (virbr0)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ga
: 8.0 (Liberty)
Assignee: Javier Peña
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 12:44 UTC by Lee Yarwood
Modified: 2016-04-07 20:59 UTC (History)
11 users (show)

Fixed In Version: openstack-packstack-7.0.0-0.8.dev1661.gaf13b7e.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-07 20:59:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0603 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 Enhancement Advisory 2016-04-08 00:53:53 UTC
OpenStack gerrit 133084 None None None Never
OpenStack gerrit 209158 None None None Never

Description Lee Yarwood 2014-07-18 12:44:29 UTC
Description of problem:
The default libvirt network (virbr0) should be disabled on compute nodes to avoid any risk of networking issues or confusion to users. 

Version-Release number of selected component (if applicable):
openstack-packstack-2014.1.1-0.32.1.dev1209.el7ost.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Use packstack to provision an environment.

Actual results:
The default libvirt network is present and active.

Expected results:
The default libvirt network should be removed.

Additional info:

Comment 2 Javier Peña 2014-11-06 16:20:58 UTC
In theory, https://review.openstack.org/41319 was already doing that. However, the puppet template only depended on the libvirt package, when it should depend on the libvirtd service because it is running virsh commands.

Proposed https://review.openstack.org/133084 as a fix to do that properly.

Comment 7 Gaël Chamoulaud 2015-08-04 16:18:48 UTC
Backport into icehouse branch done! https://review.openstack.org/#/c/209158/

Comment 8 Ivan Chavero 2015-08-12 05:05:00 UTC
can i have pm and qa acks for this bug?
thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Ofer Blaut 2016-03-02 09:01:14 UTC
Tested 

openstack-packstack-7.0.0-0.12.dev1699.g8f54936.el7ost.noarch

Comment 15 errata-xmlrpc 2016-04-07 20:59:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html


Note You need to log in before you can comment on or make changes to this bug.