Bug 1121166 - Product sync status not correct for products with syncable and non-syncable content
Summary: Product sync status not correct for products with syncable and non-syncable c...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 14:16 UTC by David Davis
Modified: 2016-04-22 16:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:28:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6691 None None None 2016-04-22 16:11:03 UTC

Description David Davis 2014-07-18 14:16:53 UTC
Description of problem:

In the sync overview widget, the status for products that have been synced but have non-syncable content is incorrect. It looks like start_time is not being populated in the Product record correctly.


Version-Release number of selected component (if applicable):

1.5

How reproducible:

Always


Steps to Reproduce:
1. Create a sat6 product
2. Create sat6 and sat6-tools repos synced from a yum repo
3. Create sat6-puppet repo with no sync enabled
4. Sync the sat6 yum repos
5. Check dashboard page in the Sync Overview widget


Actual results:

It shows "sat6  not_synced" in the Sync Overview widget even though all of the syncable repos have been.


Expected results:

Status should be "synced".


Additional info:

From https://bugzilla.redhat.com/show_bug.cgi?id=1021065#c3

Comment 2 Bryan Kearney 2014-07-23 16:04:29 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6691 has been closed
-------------
David Davis
Applied in changeset commit:katello|f1bfff08e97a4c3f6c682cf24a737a253f30b816.

Comment 4 Corey Welton 2014-08-01 14:37:11 UTC
This appears fixed, but I think it introduced another bz.  I will write it up separately.  Verified in Satellite-6.0.4-RHEL-6-20140730.0/

Comment 6 Bryan Kearney 2014-09-11 12:28:06 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.