Bug 1121171 - missing interface definitions
Summary: missing interface definitions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 14:34 UTC by Milos Malik
Modified: 2016-11-04 02:17 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-3.13.1-82.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:17:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2283 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2016-11-03 13:36:25 UTC

Description Milos Malik 2014-07-18 14:34:52 UTC
Description of problem:

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.12.1-155.el7.noarch
selinux-policy-doc-3.12.1-155.el7.noarch
selinux-policy-mls-3.12.1-155.el7.noarch
selinux-policy-sandbox-3.12.1-155.el7.noarch
selinux-policy-devel-3.12.1-155.el7.noarch
selinux-policy-3.12.1-155.el7.noarch
selinux-policy-minimum-3.12.1-155.el7.noarch

How reproducible:
always

Steps to Reproduce:
# sepolgen-ifgen -v -d

Actual results:
Missing interface definition for userdom_manage_user_tmpfs_files
Missing interface definition for logging_send_sylog_msg

Expected results:
 * all used interfaces are defined

Comment 1 Lukas Vrabec 2014-10-06 12:15:53 UTC
commit befb9f53a9e0e604104970e1b7a9912d1baa5996
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Oct 6 14:15:23 2014 +0200

    Added sendmail_domtrans_unconfined interface

commit afcb311c3a20af738f3dc3e9b82b5750603481e9
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Oct 6 14:07:14 2014 +0200

    Fix broken interfaces

Comment 2 Lukas Vrabec 2014-10-06 13:30:16 UTC
commit ac349e48dfc9b7a22ea3b232237161877b962185
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Oct 6 15:30:01 2014 +0200

    Add userdom_manage_user_tmpfs_files interface

Comment 8 Milos Malik 2014-12-12 14:18:44 UTC
Compile test for jabber_admin failed.
Compiling targeted compiletest module
compiletest.te":43:ERROR 'unknown type jabberd_lock_t' at token ';' on line 4524:
	allow sepolicy_domain_t jabberd_lock_t:dir { open read getattr lock search ioctl add_name remove_name write };
#line 43
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
/usr/bin/checkmodule:  loading policy configuration from tmp/compiletest.tmp
make: *** [tmp/compiletest.mod] Error 1

Comment 9 Milos Malik 2014-12-12 14:25:08 UTC
Compile test for pcp_read_lib_files failed.
Compiling targeted compiletest module
compiletest.te":43:ERROR 'unknown type sepolicy_domain' at token ';' on line 4194:
	allow sepolicy_domain var_t:dir { getattr search open };
#line 43
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
/usr/bin/checkmodule:  loading policy configuration from tmp/compiletest.tmp
make: *** [tmp/compiletest.mod] Error 1

Comment 10 Milos Malik 2014-12-12 14:27:52 UTC
Compile test for rpm_admin failed.
Compiling targeted compiletest module
compiletest.te":43:ERROR 'unknown type rpm_cache_t' at token ';' on line 4504:
	allow sepolicy_domain_t rpm_cache_t:dir { open read getattr lock search ioctl add_name remove_name write };
#line 43
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
/usr/bin/checkmodule:  loading policy configuration from tmp/compiletest.tmp
make: *** [tmp/compiletest.mod] Error 1

Comment 11 Milos Malik 2014-12-12 14:28:36 UTC
Compile test for samba_admin failed.
Compiling targeted compiletest module
compiletest.te":43:ERROR 'unknown type samba_unconfined_script_t' at token ';' on line 4234:
		allow sepolicy_domain_t samba_unconfined_script_t:process ptrace;
#line 43
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
/usr/bin/checkmodule:  loading policy configuration from tmp/compiletest.tmp
make: *** [tmp/compiletest.mod] Error 1

Comment 12 Milos Malik 2014-12-12 14:29:41 UTC
Compile test for sendmail_create_log failed.
Compiling targeted compiletest module
compiletest.te:43: Warning: sendmail_create_log(sepolicy_domain_t) has been deprecated, use sendmail_log_filetrans_sendmail_log() instead.
compiletest.te":43:ERROR 'syntax error' at token ';' on line 4242:
	type_transition sepolicy_domain_t var_log_t: sendmail_log_t ;
#line 43
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
/usr/bin/checkmodule:  loading policy configuration from tmp/compiletest.tmp
make: *** [tmp/compiletest.mod] Error 1

Comment 13 Milos Malik 2014-12-12 14:36:12 UTC
Compile test for unconfined_server_dbus_chat failed.
Compiling targeted compiletest module
compiletest.te":43:ERROR 'unknown class dbus' at token ';' on line 4168:
        allow sepolicy_domain_t unconfined_service_t:dbus send_msg;
#line 43
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
/usr/bin/checkmodule:  loading policy configuration from tmp/compiletest.tmp
make: *** [tmp/compiletest.mod] Error 1

Comment 14 Miroslav Grepl 2015-01-09 14:08:27 UTC
(In reply to Milos Malik from comment #12)
> Compile test for sendmail_create_log failed.
> Compiling targeted compiletest module
> compiletest.te:43: Warning: sendmail_create_log(sepolicy_domain_t) has been
> deprecated, use sendmail_log_filetrans_sendmail_log() instead.
> compiletest.te":43:ERROR 'syntax error' at token ';' on line 4242:
> 	type_transition sepolicy_domain_t var_log_t: sendmail_log_t ;
> #line 43
> /usr/bin/checkmodule:  error(s) encountered while parsing configuration
> /usr/bin/checkmodule:  loading policy configuration from tmp/compiletest.tmp
> make: *** [tmp/compiletest.mod] Error 1

This is sepolicy bug.

Comment 23 Lukas Vrabec 2015-07-14 13:43:08 UTC
Milos,
Could you update this bug? 
Thank you!

Comment 25 Lukas Vrabec 2015-07-14 14:39:29 UTC
commit ad69bdd08d82df01a8b1b737a182c56942bfecc9
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Tue Jul 14 16:17:40 2015 +0200

    Fix *_admin intefaces where body is not consistent with header.

Comment 32 Mike McCune 2016-03-28 22:58:03 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 42 errata-xmlrpc 2016-11-04 02:17:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html


Note You need to log in before you can comment on or make changes to this bug.