Bug 1121172 - 422 Unprocessable Entity error with rebased foreman
Summary: 422 Unprocessable Entity error with rebased foreman
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: Foreman (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: Installer
Assignee: Marek Hulan
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On: 1121697
Blocks: 1105594
TreeView+ depends on / blocked
 
Reported: 2014-07-18 14:35 UTC by John Eckersberg
Modified: 2015-06-04 22:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:05:40 UTC


Attachments (Terms of Use)
foreman installer log (793.25 KB, text/x-log)
2014-07-18 14:35 UTC, John Eckersberg
no flags Details
foreman production log (278.95 KB, text/plain)
2014-07-18 14:35 UTC, John Eckersberg
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description John Eckersberg 2014-07-18 14:35:20 UTC
Created attachment 919105 [details]
foreman installer log

With:

rhel-osp-installer-0.1.1-1.el6ost.noarch
foreman-1.6.0.29-1.el6sat.noarch

I get the following error out of rhel-osp-installer:

 Could not set 'present' on ensure: 422 Unprocessable Entity at 12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp
 Could not set 'present' on ensure: 422 Unprocessable Entity at 12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[staypuft.example.org]/ensure: change from absent to present failed: Could not set 'present' on ensure: 422 Unprocessable Entity at 12:/usr/share/foreman-installer/modules/foreman_proxy/manifests/register.pp
Installing             Done                                               [100%] [.................................................................................................................................]
Not running provisioning configuration since installation encountered errors, exit code was 6
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/foreman-installer/foreman-installer.log

More info in the foreman-installer.log and foreman production.log.

Comment 1 John Eckersberg 2014-07-18 14:35:55 UTC
Created attachment 919106 [details]
foreman production log

Comment 3 John Eckersberg 2014-07-21 15:45:27 UTC
Bug 1121697 I've filed against foreman-proxy seems to be the root cause of this.

Comment 5 Mike Burns 2014-08-05 17:50:53 UTC
Pretty sure this is fixed, moving to ON_QA

Comment 6 Ami Jeain 2014-08-07 10:18:43 UTC
failed while trying to run clean.sh after deployment got stuck:
I had a nova network deployment with 1 controller and 2 computes, and while the deploymeny got stuck in compute2, I ran clean.sh and I got:

# ./clean.sh 
maca25400702875.example.com is being deleted.
Traceback (most recent call last):
  File "./clean-staypuft-vms.py", line 77, in <module>
    main()
  File "./clean-staypuft-vms.py", line 74, in main
    clean_hosts(host,encoded_string)
  File "./clean-staypuft-vms.py", line 48, in clean_hosts
    url=urllib2.urlopen(request) 
  File "/usr/lib64/python2.7/urllib2.py", line 127, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib64/python2.7/urllib2.py", line 410, in open
    response = meth(req, response)
  File "/usr/lib64/python2.7/urllib2.py", line 523, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib64/python2.7/urllib2.py", line 448, in error
    return self._call_chain(*args)
  File "/usr/lib64/python2.7/urllib2.py", line 382, in _call_chain
    result = func(*args)
  File "/usr/lib64/python2.7/urllib2.py", line 531, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 422: Unprocessable Entity

Comment 7 Mike Burns 2014-08-07 21:56:28 UTC
clean.sh is a QE developed script being run on a deployed foreman environment.  The unprocessable entry error as reported in this bug is for the execution of the rhel-osp-installer script (and specifically when entering subscription-manager details)

Comment 8 errata-xmlrpc 2014-08-21 18:05:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.