Bug 1121183 - fedora-updates.repo has no 'metadata_expire' setting
Summary: fedora-updates.repo has no 'metadata_expire' setting
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1130685
TreeView+ depends on / blocked
 
Reported: 2014-07-18 15:04 UTC by Ales Kozumplik
Modified: 2014-09-30 23:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 14:28:10 UTC


Attachments (Terms of Use)

Description Ales Kozumplik 2014-07-18 15:04:09 UTC
Hello,

the update repo is missing the metadata_expire setting. This is very important for package managers so they know when the time is right to refresh the cache. However it shouldn't be too short so infra and users' bandwidth is not being wasted. Currently, the default value that Yum uses in this case is 6 hours, which means very frequent checking, while DNF uses 48 hours which in some cases means some of the .rpm packges are gone when their download is attempted.

Comment 1 Ales Kozumplik 2014-09-08 13:48:26 UTC
Same problem with fedora-rawhide.repo.

Comment 2 Dennis Gilmore 2014-09-08 14:14:49 UTC
dnf should use the same default as yum

Comment 3 Dennis Gilmore 2014-09-08 14:17:39 UTC
regardless of that in fedora 21 all the repo files have metadata_expire set

Comment 4 Ales Kozumplik 2014-09-09 06:42:29 UTC
(In reply to Dennis Gilmore from comment #3)
> regardless of that in fedora 21 all the repo files have metadata_expire set

Dennis, let's just please keep it open until the new f21 and rawhide release packages are built. 

Fine by me if this is considered an RFE and not a bug, but the default was changed in DNF after careful evaluation of other existing repositories which do not change as frequently as Fedoras. Most of them don't have metalinks set up and so redownloading the same metadata all the time wastes people's bandwidth.

Users first.

Thanks!

Comment 5 Ales Kozumplik 2014-09-09 06:50:50 UTC
Or at least please do the change in https://git.fedorahosted.org/cgit/fedora-repos.git/tree/fedora-updates.repo or wherever the upstream .repo files are held now so this can be CLOSED UPSTREAM.

Comment 6 Dennis Gilmore 2014-09-09 14:28:10 UTC
Ales, its already upstream and has been for awhile.look at any fedora 21 system and you will see.

Comment 8 Ales Kozumplik 2014-09-09 14:36:58 UTC
Sorry, you're right, just checked in on a recent rawhide VM.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.