Bug 1121185 - When using rabbitmq AMQP traffic should be load balanced accross all nodes
Summary: When using rabbitmq AMQP traffic should be load balanced accross all nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Installer
Assignee: John Eckersberg
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 15:07 UTC by Steve Reichard
Modified: 2016-04-26 22:41 UTC (History)
7 users (show)

Fixed In Version: openstack-foreman-installer-2.0.17-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:05:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Steve Reichard 2014-07-18 15:07:16 UTC
Description of problem:

Using O-F-I, Iwas able to install a Nove Net HA config taht used rabbitmq for AMQP.

Looking at the haproxy.conf, I noticed:


listen amqp
  bind 10.19.139.3:5672
  mode  tcp
  option  tcplog
  stick  on dst
  stick-table  type ip size 2
  timeout  client 120s
  timeout  server 120s
  server ospha1 10.19.139.31:5672  check
  server ospha2 10.19.139.32:5672  check
  server ospha3 10.19.139.33:5672  check



Which directs traffic to only one node.  I beleive for rabbit all nodes should be used.



Version-Release number of selected component (if applicable):


[root@ospha-inst config]# yum list installed | grep -e openstack -e foreman -e puppet
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
foreman.noarch                      1.6.0.21-1.el6sat  @RHEL-6-Server-OS-Foreman
foreman-installer.noarch            1:1.5.0-0.4.RC2.el6ost
foreman-mysql2.noarch               1.6.0.21-1.el6sat  @RHEL-6-Server-OS-Foreman
foreman-proxy.noarch                1.6.0.8-1.el6sat   @RHEL-6-Server-OS-Foreman
foreman-selinux.noarch              1.6.0-2.el6sat     @RHEL-6-Server-OS-Foreman
openstack-foreman-installer.noarch  2.0.15-1.el6ost    @RHEL-6-Server-OS-Foreman
openstack-puppet-modules.noarch     2014.1-19.1.el6ost @RHEL-6-Server-OS-Foreman
puppet.noarch                       3.6.2-1.1.el6      @RHEL-6-Server-OS-Foreman
puppet-server.noarch                3.6.2-1.1.el6      @RHEL-6-Server-OS-Foreman
ruby193-rubygem-foreman_openstack_simplify.noarch
rubygem-foreman_api.noarch          0.1.11-4.el6sat    @RHEL-6-Server-OS-Foreman
rubygem-hammer_cli_foreman.noarch   0.1.0-6.el6sat     @RHEL-6-Server-OS-Foreman
rubygem-hammer_cli_foreman-doc.noarch
[root@ospha-inst config]# 



How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 John Eckersberg 2014-07-18 16:17:59 UTC
Steve, sanity check me since I am an haproxy newbie.  I should just need to remove these two lines to achieve the expected behavior, correct?

  stick  on dst
  stick-table  type ip size 2

Comment 3 Steve Reichard 2014-07-18 17:29:12 UTC
That was my understanding but more importantly this agrees with what Ryan O'Hara e-mailed me:


Just take out the 'stick on dst' and the 'stick-table type ip size
2' and you're good.

Ryan

Comment 4 John Eckersberg 2014-07-18 19:23:03 UTC
https://github.com/redhat-openstack/astapor/pull/321

Comment 8 Leonid Natapov 2014-08-18 11:22:17 UTC
openstack-foreman-installer-2.0.17-1.el6ost

listen amqp
  bind 192.168.0.99:5672
  mode  tcp
  option  tcplog
  timeout  client 120s
  timeout  server 120s
  server mac047d7b627d5a.example.com 192.168.0.2:5672  check inter 1s
  server mac047d7b685a04.example.com 192.168.0.5:5672  check inter 1s
  server mac047d7b61754e.example.com 192.168.0.3:5672  check inter 1s



stick  on dst
stick-table  type ip size 2 were removed.

Comment 9 errata-xmlrpc 2014-08-21 18:05:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.