Bug 1121193 - glusterd log is full of warning 'readv on /var/run/<no>.socket failed (Invalid argument)' . (almost 2k+ message in less than 3 hours and still counting)
Summary: glusterd log is full of warning 'readv on /var/run/<no>.socket failed (Invali...
Keywords:
Status: CLOSED DUPLICATE of bug 1113954
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Bug Updates Notification Mailing List
QA Contact: amainkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 15:29 UTC by Rachana Patel
Modified: 2015-04-20 11:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 06:07:51 UTC


Attachments (Terms of Use)

Description Rachana Patel 2014-07-18 15:29:04 UTC
Description of problem:
=======================
glusterd log is full of warning 

[2014-07-18 05:17:22.356988] W [socket.c:529:__socket_rwv] 0-management: readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed (Invalid argument)
[2014-07-18 05:17:25.357586] W [socket.c:529:__socket_rwv] 0-management: readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed (Invalid argument)
[2014-07-18 05:17:28.358178] W [socket.c:529:__socket_rwv] 0-management: readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed (Invalid argument)
[2014-07-18 05:17:31.358752] W [socket.c:529:__socket_rwv] 0-management: readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed (Invalid argument)
[2014-07-18 05:17:34.359321] W [socket.c:529:__socket_rwv] 0-management: readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed (Invalid argument)
[2014-07-18 05:17:37.359903] W [socket.c:529:__socket_rwv] 0-management: readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed (Invalid argument)
[2014-07-18 05:17:40.360523] W [socket.c:529:__socket_rwv] 0-management: readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed (Invalid argument)
[2014-07-18 05:17:43.361135] W [socket.c:529:__socket_rwv] 0-management: readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed (Invalid argument)


more than 3k message in 3+ hours

[root@OVM4 core]# grep 'readv on /var/run/9a99795244cae05ee896f56bc0a61595.socket failed' /var/log/glusterfs/etc-glusterfs-glusterd.vol.log | wc -l
3901



Version-Release number:
=======================
3.6.0.24-1.el6rhs.x86_64


Steps to Reproduce:
===================
not known



why warning is repeated every few seconds?

Comment 2 Atin Mukherjee 2014-07-21 06:07:51 UTC
http://review.gluster.org/#/c/8210/ should address this issue (need to get into upstream yet). There is already a RHS bug : 1113954 raised for the similar issue and hence marking it duplicate.

*** This bug has been marked as a duplicate of bug 1113954 ***


Note You need to log in before you can comment on or make changes to this bug.