Bug 1121203 - oo-accept-node does not validate that EXTERNAL_ETH_DEV has a globally scoped IPv4 addres
Summary: oo-accept-node does not validate that EXTERNAL_ETH_DEV has a globally scoped ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Miciah Dashiel Butler Masters
QA Contact: libra bugs
URL:
Whiteboard:
Depends On: 1121206
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 15:52 UTC by Miciah Dashiel Butler Masters
Modified: 2014-08-04 13:27 UTC (History)
8 users (show)

Fixed In Version: openshift-origin-node-util-1.22.13.1-1.el6op
Doc Type: Bug Fix
Doc Text:
The oo-accept-node script did not check that the external network device (as specified by the EXTERNAL_ETH_DEV parameter in the /etc/openshift/node.conf file, or the default, eth0) had a globally scoped IPv4 address. If a node host's external network device were not properly configured, such misconfiguration might not have been detected until the platform tried to perform certain operations. For example, creating a scalable application fails in the port-proxy code if the node cannot find a globally scoped IPv4 address on its external network device. This bug fix adds a new test, check_ext_net_dev_addr, to the oo-accept-node script, and the script now fails if the external network device does not have a globally scoped IPv4 address.
Clone Of:
: 1121206 (view as bug list)
Environment:
Last Closed: 2014-08-04 13:27:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0999 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.1.4 bug fix and enhancement update 2014-08-04 17:26:43 UTC

Description Miciah Dashiel Butler Masters 2014-07-18 15:52:18 UTC
Description of problem:

oo-iptables-port-proxy requires that EXTERNAL_ETH_DEV be set to a network interface that has a globally scoped IPv4 address.  oo-accept-node does not check that this requirement is met.


How reproducible:

Completely.


Steps to Reproduce:

1. Install an OpenShift Enterprise PaaS with 1 node.

2. Set EXTERNAL_ETH_DEV=lo in /etc/openshift/node.conf on the node in Step 1.

3. Run oo-accept-node.


Actual results:

oo-accept-node does not complain that the network interface specified by EXTERNAL_ETH_DEV does not have a globally scoped IPv4 address.


Expected results:

oo-accept-node should warn about the problem.


Additional info:

See bug 1121195.

Comment 1 Miciah Dashiel Butler Masters 2014-07-22 17:18:47 UTC
PR: https://github.com/openshift/enterprise-server/pull/333

Comment 4 Anping Li 2014-07-24 04:41:07 UTC
Verified and pass on puddle-2-1-2014-07-23

[root@nd1 openshift]# oo-accept-node -v
INFO: using default accept-node extensions
INFO: loading node configuration file /etc/openshift/node.conf
INFO: loading resource limit file /etc/openshift/resource_limits.conf
INFO: finding external network device
INFO: checking that external network device has a globally scoped IPv4 address
FAIL: SEVERE: lo has no globally scoped IPv4 address
<snip--->
INFO: checking cartridge repository
1 ERRORS

Comment 6 errata-xmlrpc 2014-08-04 13:27:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0999.html


Note You need to log in before you can comment on or make changes to this bug.