Bug 1121239 - docker pull from custom registry errors on Invalid Namespace Name
Summary: docker pull from custom registry errors on Invalid Namespace Name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: John Keck
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1109938 1138364
TreeView+ depends on / blocked
 
Reported: 2014-07-18 17:52 UTC by Devan Goodwin
Modified: 2019-03-06 01:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 20:46:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1266 normal SHIPPED_LIVE docker bug fix and enhancement update 2014-09-19 00:45:12 UTC

Description Devan Goodwin 2014-07-18 17:52:40 UTC
Description of problem:

Attempting to pull an image from a custom docker registry errors out with:

Error: Invalid namespace name (docker.usersys.redhat.com), only [a-z0-9_] are allowed, size between 4 and 30


Version-Release number of selected component (if applicable):

docker-1.0.0-11.el7.x86_64


Steps to Reproduce:

1. Install new docker rpm as referenced above from http://download.devel.redhat.com/brewroot/repos/extras-rhel-7.1-candidate/latest/

2. docker pull docker-registry.usersys.redhat.com/brew/rhel7:latest 

Actual results:

[root@dgoodwin-rhel7-dockerci hudson]# docker pull docker-registry.usersys.redhat.com/brew/rhel7:latest 
2014/07/18 13:50:44 Error: Invalid namespace name (docker-registry.usersys.redhat.com), only [a-z0-9_] are allowed, size between 4 and 30



Additional info:

Problem does not occur with docker-1.0.0-2.el7.x86_64, nor the version currently in Fedora 20.

Comment 2 Jan Pazdziora 2014-07-21 13:08:31 UTC
Bug is also present with docker-1.1.1-1.el7.x86_64.

Comment 3 Jan Pazdziora 2014-07-21 13:23:14 UTC
The last build without this bug is docker-1.0.0-8.el7, docker-1.0.0-9.el7 is the first one to fail.

Comment 4 Daniel Walsh 2014-07-22 16:55:16 UTC
Fixed in  docker-1.1.1-2.el7

Comment 5 Luwen Su 2014-08-05 09:58:02 UTC
# rpm -q docker
docker-1.1.2-6.el7.x86_64

# docker pull docker-registry.usersys.redhat.com/brew/rhel7:latest 
Pulling repository docker-registry.usersys.redhat.com/brew/rhel7
81ed26a5d836: Downloading [==>                                                ] 2.602 MB/51.92 MB 1m31s

Set Verified

Comment 6 errata-xmlrpc 2014-09-18 20:46:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1266.html


Note You need to log in before you can comment on or make changes to this bug.