Bug 1121244 - WebUI gets raw JSON GET request when session times out
Summary: WebUI gets raw JSON GET request when session times out
Keywords:
Status: CLOSED DUPLICATE of bug 1118444
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-18 18:32 UTC by Shannon Hughes
Modified: 2014-07-24 12:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 12:13:45 UTC


Attachments (Terms of Use)

Description Shannon Hughes 2014-07-18 18:32:23 UTC
Description of problem:

Let the session timeout on the webui. click on the red hat subscriptions link. The request correctly sends you to login page. after logging in I am redirected to the following: 

https://sat6.katello.lan/katello/api/v2/organizations/1/subscriptions

and the raw json is spit on screen

{"total":1,"subtotal":1,"offset":null,"limit":null,"search":null,"sort":{"by":null,"order":null},"results":[{"":null,"id":"40284882473b2ab401474184dca60169","product_name":"Red Hat Employee Subscription","start_date":"2013-04-24","end_date":"2022-01-01","available":5,"quantity":5,"consumed":0,"account_number":"540155","contract_number":"10169621","support_level":"SELF-SUPPORT","product_id":"ES0113909","virt_only":false,"sockets":128,"ram":0,"instance_multiplier":null,"stacking_id":"","multi_entitlement":false}]}




Expected results:


Additional info:

Comment 1 RHEL Product and Program Management 2014-07-18 18:43:50 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2014-07-24 12:13:45 UTC

*** This bug has been marked as a duplicate of bug 1118444 ***


Note You need to log in before you can comment on or make changes to this bug.