Bug 1121251 - rhsm-debug system does not bash-complete the new "--no-subscriptions" option
Summary: rhsm-debug system does not bash-complete the new "--no-subscriptions" option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-07-18 18:54 UTC by John Sefler
Modified: 2014-10-14 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:47:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2014-07-18 18:54:30 UTC
Description of problem:
After the implementation of the new "--no-subscriptions" option to satisfy bug 1114117, we should also enable it for bash-completion.

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager bash-completion
subscription-manager-1.12.7-1.git.6.f8bf245.el6.x86_64
bash-completion-1.3-7.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# rhsm-debug system --help 
Usage: rhsm-debug system [OPTIONS] 

Assemble system information as a tar file or directory

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --destination=DESTINATION
                        the destination location of the result; default is
                        /tmp
  --no-archive          data will be in an uncompressed directory
  --sos                 only data not already included in sos report will be
                        collected
  --no-subscriptions    exclude subscription data
  ^^^^^^^^^^^^^^^^^^
Notice this new option

[root@jsefler-6 ~]# rhsm-debug system --<TAB><TAB>
--destination    --no-archive     --proxypassword  --sos
--help           --proxy          --proxyuser   

Actual results:
above

Expected results:
the tab tab bash completion list should include "--no-subscriptions"


Additional info:

Comment 2 Rehana 2014-07-30 07:31:07 UTC
Retested on 

# subscription-manager  version
server type: This system is currently not registered.
subscription management server: 0.9.21-1
subscription management rules: 5.11
subscription-manager: 1.12.10-1.el6
python-rhsm: 1.12.5-1.el6

# rpm -qa | grep bash-completion
bash-completion-1.3-7.el6.noarch

# rhsm-debug system --help 
Usage: rhsm-debug system [OPTIONS] 

Assemble system information as a tar file or directory

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --destination=DESTINATION
                        the destination location of the result; default is
                        /tmp
  --no-archive          data will be in an uncompressed directory
  --sos                 only data not already included in sos report will be
                        collected
  --no-subscriptions    exclude subscription data


# rhsm-debug system --<tab><tab>
--destination       --no-archive        --proxy             --proxyuser         
--help              --no-subscriptions  --proxypassword     --sos               


Observed that tab tab bash completion list now includes new option "--no-subscriptions"

Marking this bug to "Verified"

Comment 3 errata-xmlrpc 2014-10-14 07:47:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.