Bug 1121258 - neither valid_lft preferred_lft are listed in the ip-address(8) manpage
Summary: neither valid_lft preferred_lft are listed in the ip-address(8) manpage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 7.3
Assignee: Phil Sutter
QA Contact: Marek Marusic
URL:
Whiteboard:
Depends On:
Blocks: 1274917 1364088
TreeView+ depends on / blocked
 
Reported: 2014-07-18 19:16 UTC by Ben Woodard
Modified: 2016-11-03 23:32 UTC (History)
12 users (show)

Fixed In Version: iproute-3.10.0-57.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1121261 (view as bug list)
Environment:
Last Closed: 2016-11-03 23:32:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2162 normal SHIPPED_LIVE iproute bug fix and enhancement update 2016-11-03 13:14:33 UTC

Description Ben Woodard 2014-07-18 19:16:34 UTC
Description of problem:

dracut sets interface parameters called valid_lft and preferred_lft but neither of these options are are documented in the man page. The values set are also listed when you print the interface's configuration.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever


but it takes a bit of digging to figure out what these values mean. These should be documented in the man page so that people know what they mean and how to set them.

Version-Release number of selected component (if applicable):
3.9.0-13

How reproducible:
always

Comment 7 Pavel Šimerda (pavlix) 2014-10-24 12:08:38 UTC
In RHEL 7 the manpage is called ip-address.

Comment 9 Phil Sutter 2016-06-21 21:27:19 UTC
This has been resolved as a side effect of the fix for bug 1231898.

Comment 11 Phil Sutter 2016-07-22 13:00:01 UTC
Reopening this ticket so it can be tested for in QA.

Comment 15 errata-xmlrpc 2016-11-03 23:32:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2162.html


Note You need to log in before you can comment on or make changes to this bug.