Bug 112126 - Build problem - inconsistent builds
Build problem - inconsistent builds
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openssl (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-15 03:03 EST by John Morris
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 11:23:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Morris 2003-12-15 03:03:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20030708

Description of problem:
Building this package gives variable results.  Some passes it will
build a correct package, another run it won't.  I have yet to
establish any sort of pattern, I just build it until it works.  The
problem remains constant whether the build is run as root or a normal
user, SMP or uniprocessor.  It is easy to know if a build succeeded or
not, just run ldd on
/usr/src/redhat/BUILD/openssl-0.9.7a/libssl.so.0.9.7 as soon as the
build process gets to the phase where it runs tests.  If it shows the
following it isn't going to work and you can skip the long tests:

	libcrypto.so.4 => /lib/libcrypto.so.4 (0xb74c3000)
	libdl.so.2 => /lib/libdl.so.2 (0xb74c0000)
	libz.so.1 => /usr/lib/libz.so.1 (0xb74b2000)
	libc.so.6 => /lib/tls/libc.so.6 (0xb737b000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

But if you get these links to kerberos it will work:

	libgssapi_krb5.so.2 => /usr/kerberos/lib/libgssapi_krb5.so.2 (0xb75a1000)
	libkrb5.so.3 => /usr/kerberos/lib/libkrb5.so.3 (0xb7543000)
	libcom_err.so.3 => /usr/kerberos/lib/libcom_err.so.3 (0xb7541000)
	libk5crypto.so.3 => /usr/kerberos/lib/libk5crypto.so.3 (0xb7531000)
	libresolv.so.2 => /lib/libresolv.so.2 (0xb751f000)
	libcrypto.so.4 => /lib/libcrypto.so.4 (0xb742e000)
	libdl.so.2 => /lib/libdl.so.2 (0xb742a000)
	libz.so.1 => /usr/lib/libz.so.1 (0xb741c000)
	libc.so.6 => /lib/tls/libc.so.6 (0xb72e5000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)


Version-Release number of selected component (if applicable):
openssl-0.9.7a-23

How reproducible:
Sometimes

Steps to Reproduce:
1. rpmbuild --rebuild openssl-0.9.7a-23.src.rpm


Additional info:
Full Disclosure, I'm not running on RHEL3 but am one of the
rebuilders, specifically whiteboxlinux.org.  This problem has been
consistent since taroon-beta and since everything else builds and has
stood up to a fair amount of outside testing it was time to get this
bug reported.  If it fails to appear under your build conditions that
in itself is an important datapoint.
Comment 1 Tomas Mraz 2005-02-04 11:23:31 EST
Doesn't seem to happen here.

Note You need to log in before you can comment on or make changes to this bug.