Bug 1121272 - subscription-manager repos --enable=<REPOID> FAILS to enable the repo
Summary: subscription-manager repos --enable=<REPOID> FAILS to enable the repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-07-18 20:39 UTC by John Sefler
Modified: 2014-10-14 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:47:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2014-07-18 20:39:49 UTC
Description of problem:
The "--enable" option to "subscription-manager repos" fails to 
enable the repo.  Instead, it creates a disabled repo-override.


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.21-1
subscription management rules: 5.11
subscription-manager: 1.12.7-1.git.14.eaae6e0.el6
python-rhsm: 1.12.4-1.git.1.33a7d26.el6


How reproducible:
Note that this was working previously in subscription-manager: 1.12.4-1.el6


Steps to Reproduce:
1. register and subscribe (not shown)
[root@jsefler-6 ~]# subscription-manager repos --list | head -8
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   awesomeos
Repo Name: awesomeos
Repo URL:  https://cdn.qa.redhat.com/path/to/$basearch/$releasever/awesomeos
Enabled:   0

[root@jsefler-6 ~]# subscription-manager repos --enable=awesomeos
Repo 'awesomeos' is disabled for this system.
[root@jsefler-6 ~]# subscription-manager repo-override --list
Repository: awesomeos
  enabled: 0



Actual results:
Notice that I specified "--enable", yet the feedback and override indicate disabled. 

Expected results:
Repo 'awesomeos' is enabled for this system.

Comment 2 Carter Kozak 2014-07-18 20:52:52 UTC
commit d623642f68d2e0e547f25a309e2696091a64ba07
Author: ckozak <ckozak@redhat.com>
Date:   Fri Jul 18 16:51:16 2014 -0400

    1121272: fix typo that blocked enabling repos via CLI

Comment 4 Rehana 2014-07-30 06:51:44 UTC
Retested on ,

# subscription-manager  version
server type: Red Hat Subscription Management
subscription management server: 0.9.21-1
subscription management rules: 5.11
subscription-manager: 1.12.10-1.el6
python-rhsm: 1.12.5-1.el6

Steps;
1.Register and attach subscriptions
2.Repo list # subscription-manager  repos --list
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   content-label-empty-gpg
Repo Name: content-emptygpg
Repo URL:  https://cdn.redhat.com/foo/path
Enabled:   0

Repo ID:   content-label
Repo Name: content
Repo URL:  https://cdn.redhat.com/foo/path
Enabled:   0
<snip>

3.enable repo

# subscription-manager  repos --enable=content-label-empty-gpg
Repo 'content-label-empty-gpg' is enabled for this system. --> correct message is displayed now 

# subscription-manager repo-override --list
Repository: content-label-empty-gpg
  enabled: 1

# subscription-manager  repos --list
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   content-label-empty-gpg
Repo Name: content-emptygpg
Repo URL:  https://cdn.redhat.com/foo/path
Enabled:   1

Repo ID:   content-label
Repo Name: content
Repo URL:  https://cdn.redhat.com/foo/path
Enabled:   0

<snip>


Above test steps demonstrates that correct message is displayed after enabling repo , hence marking this bug verified

Comment 6 errata-xmlrpc 2014-10-14 07:47:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.