Bug 1121298 - can't install drupal from code
Summary: can't install drupal from code
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 23:47 UTC by Peter Ruan
Modified: 2016-05-25 13:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-25 07:06:24 UTC


Attachments (Terms of Use)

Description Peter Ruan 2014-07-18 23:47:50 UTC
Description of problem:
I keep getting a 500 when trying to install drupal with rhc app create --from-code option.

Version-Release number of selected component (if applicable):

http://etherpad.corp.redhat.com/puddle-2-1-2014-07-18

How reproducible:
always.

Steps to Reproduce:
1. rhc app create tjyjulvn php-5.4 --from-code https://github.com/drupal/drupal#7.x
2.
3.

Actual results:
      Creating application 'tjyjulvn' ... Unable to complete the requested operation due to: The server broker.ose21z.example.com that your application is running on failed to respond in time.  This may be due to a system restart.
      Reference ID: 77eecbb0633f4989c372e7023efadcd1

Expected results:
success.

Additional info:
broker.log

Comment 2 Luke Meyer 2014-07-19 02:38:34 UTC
Seems likely it's just taking longer than the timeouts set. Does it work if you expand timeouts?

https://access.redhat.com/documentation/en-US/OpenShift_Enterprise/2/html-single/Administration_Guide/index.html#Component_Timeout_Value_Locations

The broker mco timeout is the shortest, 240 seconds = 3 minutes.  How long does it take to deploy if not --from-code?

Comment 3 Luke Meyer 2014-07-24 14:57:41 UTC
Ping on this - any response to comment 2? Will close shortly if not.

Comment 4 Peter Ruan 2014-07-25 06:07:44 UTC
Hi Luke,
  Do you want me to modify the timeout value and try it?  Do you know how I can create the drupal app w/o the --from-code option?

Thanks,
-peter

Comment 5 Johnny Liu 2014-07-25 06:28:49 UTC
Hmmm, I could not reproduce this bug, 

$ rhc app create tjyjulvn php-5.4 --from-code https://github.com/drupal/drupal#7.x
Application Options
-------------------
Domain:      jialiu
Cartridges:  php-5.4
Source Code: https://github.com/drupal/drupal#7.x
Gear Size:   default
Scaling:     no

Creating application 'tjyjulvn' ... done


Waiting for your DNS name to be available ... done

Cloning into 'tjyjulvn'...
Warning: Permanently added 'tjyjulvn-jialiu.ose-21.com.cn,10.3.13.225' (RSA) to the list of known hosts.

Your application 'tjyjulvn' is now available.

  URL:        http://tjyjulvn-jialiu.ose-21.com.cn/
  SSH to:     53d1f1dfbe739b3a3c00003b@tjyjulvn-jialiu.ose-21.com.cn
  Git remote: ssh://53d1f1dfbe739b3a3c00003b@tjyjulvn-jialiu.ose-21.com.cn/~/git/tjyjulvn.git/
  Cloned to:  /home/jialiu/tjyjulvn

Run 'rhc show-app tjyjulvn' for more details about your app.


$ curl -I  http://tjyjulvn-jialiu.ose-21.com.cn/
HTTP/1.1 302 Found
Date: Fri, 25 Jul 2014 06:24:09 GMT
Server: Apache/2.2.15 (Red Hat)
Location: http://tjyjulvn-jialiu.ose-21.com.cn/install.php
Cache-Control: no-cache
Content-Type: text/html; charset=UTF-8
Connection: close


@peter, if you do not want to change mco timeout mentioned in comment 2, you could split the quick-start app creation into 2 steps, that would also avoid time out issue happen.

$ rhc app create tjyjulvn php-5.4
$ cd tjyjulvn && git remote add upstream -m master https://github.com/drupal/drupal#7.x && git pull -s recursive -X theirs upstream master && git push && cd -

Comment 6 Peter Ruan 2014-07-25 07:06:24 UTC
I tried it again with an updated puddle and it works now.  Will close this bug.

[peter@unused-16-138 <CUCUSHIFT_ONPREM> junk]# rhc app create tjyjulvn php-5.4 --from-code https://github.com/drupal/drupal#7.x
Your authorization token has expired. Please sign in now to continue on 10.14.16.216.
Password: ********

Application Options
-------------------
Domain:      ose
Cartridges:  php-5.4
Source Code: https://github.com/drupal/drupal#7.x
Gear Size:   default
Scaling:     no

Creating application 'tjyjulvn' ... done


Waiting for your DNS name to be available ... done

Cloning into 'tjyjulvn'...
Warning: Permanently added 'tjyjulvn-ose.ose21z.example.com' (RSA) to the list of known hosts.

Your application 'tjyjulvn' is now available.

  URL:        http://tjyjulvn-ose.ose21z.example.com/
  SSH to:     53d2009416ae3143320000f1@tjyjulvn-ose.ose21z.example.com
  Git remote: ssh://53d2009416ae3143320000f1@tjyjulvn-ose.ose21z.example.com/~/git/tjyjulvn.git/
  Cloned to:  /home/peter/junk/tjyjulvn

Run 'rhc show-app tjyjulvn' for more details about your app.


Note You need to log in before you can comment on or make changes to this bug.