Bug 1121299 - formail crashes handling malformed from header
Summary: formail crashes handling malformed from header
Status: CLOSED DUPLICATE of bug 1137582
Alias: None
Product: Fedora
Classification: Fedora
Component: procmail
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-19 00:01 UTC by Tavis Ormandy
Modified: 2014-09-04 13:24 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-09-04 13:24:28 UTC


Attachments (Terms of Use)
malformed mbox (3.51 KB, text/plain)
2014-07-19 00:01 UTC, Tavis Ormandy
no flags Details

Description Tavis Ormandy 2014-07-19 00:01:42 UTC
Created attachment 919216 [details]
malformed mbox

Attached mbox file crashes formail, it's from a usenet archive of alt.arts.poetry.

$ formail -v
formail v3.22 2001/09/10
$ formail -s < mbox > /dev/null 
*** Error in `formail': free(): invalid next size (fast): 0x00007f59d2e51080 ***
Segmentation fault (core dumped)

I guess it's this From header:

From: "Berryman's Legacy" <me@privacy.net"

Comment 1 Vincent Danen 2014-09-04 13:24:28 UTC

*** This bug has been marked as a duplicate of bug 1137582 ***


Note You need to log in before you can comment on or make changes to this bug.