Bug 1121306 - timezone in date header is incorrectly formatted
Summary: timezone in date header is incorrectly formatted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: geary
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-19 02:00 UTC by Aram Agajanian
Modified: 2014-08-07 15:32 UTC (History)
3 users (show)

Fixed In Version: geary-0.6.1-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-07 15:32:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 714376 None None None Never

Description Aram Agajanian 2014-07-19 02:00:06 UTC
Description of problem:
When Geary generates an email message, the date header looks like this

Date: Fri, 18 Jul 2014 01:51:36 -0004

The correct format for the time zone is -0400

I have encountered two issues due to this incorrect timezone format:

1) Messages sent to icloud.com email addresses never arrive (and are not bounced).

2) The incorrect format violates the rules of some spam detection software.

(See also https://mhvlug.org/pipermail/mhvlug/2014-July/033330.html )


Version-Release number of selected component (if applicable):
geary-0.6.1-1.fc20.x86_64


How reproducible:
Happens every time


Steps to Reproduce:
1.  Compose and send an email message
2.  Change to the Sent folder and find the email message that you just sent
3.  Look at the source of the email message


Actual results:
The time zone in the date header is incorrectly formatted.

Expected results:
The time zone in the date header should be correctly formatted.


Additional info:
This bug is fixed in the commit at the following URL.

https://git.gnome.org/browse/geary/commit/?id=f38c8c70cab0c582307f77259ef39ad8fce58fd4

Comment 1 Fedora Update System 2014-07-26 10:15:03 UTC
geary-0.6.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/geary-0.6.1-2.fc20

Comment 2 Fedora Update System 2014-07-28 03:25:54 UTC
Package geary-0.6.1-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing geary-0.6.1-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8917/geary-0.6.1-2.fc20
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2014-08-07 15:32:30 UTC
geary-0.6.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.