Bug 1121310 - [abrt] firewall-config: firewall-config:3642:onChangeService:AttributeError: 'NoneType' object has no attribute 'getSettings'
Summary: [abrt] firewall-config: firewall-config:3642:onChangeService:AttributeError: ...
Keywords:
Status: CLOSED DUPLICATE of bug 995760
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:68c85bf960d922b1dddb6764db4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-19 03:49 UTC by jstra2012
Modified: 2014-07-23 11:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 11:00:52 UTC


Attachments (Terms of Use)
File: backtrace (555 bytes, text/plain)
2014-07-19 03:49 UTC, jstra2012
no flags Details
File: environ (1.24 KB, text/plain)
2014-07-19 03:49 UTC, jstra2012
no flags Details

Description jstra2012 2014-07-19 03:49:48 UTC
Description of problem:
installed boinc into new install of fedora (after update) will not connect to boinc

Version-Release number of selected component:
firewall-config-0.3.10-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python -Es /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.15.5-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
firewall-config:3642:onChangeService:AttributeError: 'NoneType' object has no attribute 'getSettings'

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 3642, in onChangeService
    settings = service.getSettings()
AttributeError: 'NoneType' object has no attribute 'getSettings'

Local variables in innermost frame:
destination: {}
service: None
active_service: 'amanda-client'
self: <__main__.FirewallConfig object at 0x23843d0>
args: (<TreeSelection object at 0x2862cd0 (GtkTreeSelection at 0x25690d0)>,)
modules: []
ports: []

Comment 1 jstra2012 2014-07-19 03:49:50 UTC
Created attachment 919221 [details]
File: backtrace

Comment 2 jstra2012 2014-07-19 03:49:51 UTC
Created attachment 919222 [details]
File: environ

Comment 3 Jiri Popelka 2014-07-23 11:00:52 UTC

*** This bug has been marked as a duplicate of bug 995760 ***


Note You need to log in before you can comment on or make changes to this bug.