Bug 1121350 - GParted compiled with online resize support when when libparted doesn't support it
Summary: GParted compiled with online resize support when when libparted doesn't suppo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gparted
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-19 15:57 UTC by Mike Fleetwood
Modified: 2014-08-28 15:36 UTC (History)
2 users (show)

Fixed In Version: gparted-0.18.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-24 02:55:07 UTC


Attachments (Terms of Use)

Description Mike Fleetwood 2014-07-19 15:57:37 UTC
Description of problem:
Performing an online grow or shrink of a partition (while the file
system is mounted) produces the following error from libparted:

  Partition(s) 1 on /dev/sdb have been written, but we have been unable
  to inform the kernel of the change, probably because it/they are in
  use.  As a result, the old partition(s) will remain in use.  You
  should reboot now before making further changes.

This results with a failed online resize operation.  The on-disk
partition table has been changed but the kernel has not been informed.


Version-Release number of selected component (if applicable):
0.18.0 in Fedora 19, 20, rawhide, Fedora EPEL 7


How reproducible:
Every time when performing an online partition resize.


Steps to Reproduce:
1.  Resize partition while file system is mounted for supported type
    (See View > File System Support for available list)
2.
3.

Actual results:
(See description above)


Expected results:
Either online resize not allowed (very likely) or
online resize works successfully without error from libparted
(unlikely.  See additional info below).


Additional info:
This happens because GParted has been compiled with
--enable-online-resize, but libparted hasn't been patched to support
online resizing.  As I understanding online resizing won't be included
upstream in libarted until after parted 3.2 is released.

The GParted README file says this:
   If you wish to build this package with online resize support then
   the following is required:
      a)  A version of libparted that includes the online resize patch.
          At time of writing (November 2013), this patch was only
          included in Debian and derived distros with parted package
          version 2.3-14 or higher.
      b)  Linux kernel version 3.6 or higher.
   Enable with the --enable-online-resize flag:
      E.g., ./configure --enable-online-resize

I suggest this is fixed by removing --enable-online-resize from the
configuration and compilation of GParted.  I suspect Fedora and
especially Red Hat won't wan't to apply the online resize patch to
parted as Debian and Ubuntu have; but instead wait until it is included
upstream.

Thanks,
Mike Fleetwood (GParted Developer)

Comment 1 Fedora Admin XMLRPC Client 2014-07-26 17:14:02 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora Admin XMLRPC Client 2014-07-26 19:52:41 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Mike Fleetwood 2014-08-03 19:15:04 UTC
Fedora 21 and Fedora Rawhide have recently updated to parted 3.2 [1]
which includes online partition resize support [2] after all.  Therefore
GParted can be compiled with --enable-online-resize.  I have
successfully tested growing a mounted ext4 partition on Fedora Rawhide.

Therefore this bug is now only about GParted compiled on Fedora 19, 20
and Fedora EPEL 7.  Updated bug report version from rawhide to 20 to
reflect this.

Thanks,
Mike Fleetwood (GParted Developer)


[1] [parted-devel] parted-3.2 released [stable]
http://lists.alioth.debian.org/pipermail/parted-devel/2014-July/004564.html

[2] libparted: Add support for partition resize
http://git.savannah.gnu.org/cgit/parted.git/commit/?id=f09ca967a0bc443b869a6fad5b5ffe8e95c3fe9a

Comment 4 Mukundan Ragavan 2014-08-03 21:34:28 UTC
Thanks for the update, Mike. I have recently taken owvership of this package. I will try to complete the needful very soon.

Comment 5 Fedora Update System 2014-08-17 22:52:23 UTC
gparted-0.18.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gparted-0.18.0-2.fc20

Comment 6 Fedora Update System 2014-08-17 22:52:37 UTC
gparted-0.18.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gparted-0.18.0-2.fc19

Comment 7 Mukundan Ragavan 2014-08-17 22:56:41 UTC
I have submitted this as an update to F19 and F20.

It looks like EL-7 also has parted-3.1. I will compile version 0.19 of gparted for EL-7.

Comment 8 Mike Fleetwood 2014-08-18 12:31:25 UTC
Successfully tested gparted-0.18.0-2 packages on Fedora 19 & 20.
Added feedback, but anonymous doesn't help karma. :-(

Comment 9 Mukundan Ragavan 2014-08-19 01:46:43 UTC
(In reply to Mike Fleetwood from comment #8)
> Successfully tested gparted-0.18.0-2 packages on Fedora 19 & 20.
> Added feedback, but anonymous doesn't help karma. :-(

NO Worries. Thanks for commenting.

Comment 10 Fedora Update System 2014-08-19 07:03:36 UTC
Package gparted-0.18.0-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gparted-0.18.0-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9523/gparted-0.18.0-2.fc20
then log in and leave karma (feedback).

Comment 11 Mike Fleetwood 2014-08-19 19:24:50 UTC
I now have a Fedora account and given feedback so the packages now
have karma +1.

Comment 12 Fedora Update System 2014-08-24 02:55:07 UTC
gparted-0.18.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-08-28 15:36:01 UTC
gparted-0.18.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.