Bug 1121359 - Build problem (suspected) broke amrecover on the server side
Summary: Build problem (suspected) broke amrecover on the server side
Keywords:
Status: CLOSED DUPLICATE of bug 1074216
Alias: None
Product: Fedora
Classification: Fedora
Component: amanda
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-19 20:00 UTC by Trever Adams
Modified: 2014-07-28 13:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 13:20:17 UTC


Attachments (Terms of Use)

Description Trever Adams 2014-07-19 20:00:31 UTC
Description of problem (as posted to Amanda users):


Hello everyone,

So, I am not quite sure what is going on. When I try to do an amrecover,
I get the following:

Load tape normal149 now
Continue [?/Y/n/s/d]? Y
Got no header and data from server, check in amidxtaped.*.debug and
amandad.*.debug files on server

The logs hold such things as:

Sat Jul 19 05:45:39 2014: thd-0x1a16a00: amidxtaped: warning: Can't exec
"-eo": No such file or directory at
/usr/lib64/perl5/vendor_perl/Amanda/Process.pm line 176.

Sat Jul 19 05:45:39 2014: thd-0x1a16a00: amidxtaped: critical (fatal): 
-eo pid,ppid,command: No such file or directory at
/usr/lib64/perl5/vendor_perl/Amanda/Process.pm line 176.

amidxtaped:  -eo pid,ppid,command: No such file or directory at
/usr/lib64/perl5/vendor_perl/Amanda/Process.pm line 176.

/lib64/libamanda-3.3.3.so(+0x2b727)[0x7f3e7d9d0727]
/lib64/libglib-2.0.so.0(g_logv+0x209)[0x7f3e7d6c9429]
/lib64/libglib-2.0.so.0(g_log+0x8f)[0x7f3e7d6c963f]
/usr/lib64/perl5/vendor_perl/auto/Amanda/MainLoop/libMainLoop.so(+0x4925)[0x7f3e7c5ad925]
/lib64/libglib-2.0.so.0(+0x3f89449e43)[0x7f3e7d6c2e43]
/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x166)[0x7f3e7d6c22a6]
/lib64/libglib-2.0.so.0(+0x3f89449628)[0x7f3e7d6c2628]
/lib64/libglib-2.0.so.0(g_main_loop_run+0x6a)[0x7f3e7d6c2a3a]
/usr/lib64/perl5/vendor_perl/auto/Amanda/MainLoop/libMainLoop.so(_wrap_run_c+0x50)[0x7f3e7c5adca0]
/lib64/libperl.so.5.18(Perl_pp_entersub+0x5c6)[0x3008ec33e6]
/lib64/libperl.so.5.18(Perl_runops_standard+0x2e)[0x3008ebb81e]
/lib64/libperl.so.5.18(perl_run+0x300)[0x3008e52d40]
/usr/bin/perl[0x400d29]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x3f86c21d65]
/usr/bin/perl[0x400d61]


This is also not 100% consistent. I got it to do a restore once. Doing
the same steps with the same disk and date will not restore, it is all
the above.

Any ideas?

Thank you,
Trever


Version-Release number of selected component (if applicable):
amanda-3.3.3-9.fc20.x86_64
amanda-client-3.3.3-9.fc20.x86_64
amanda-libs-3.3.3-9.fc20.x86_64
amanda-server-3.3.3-9.fc20.x86_64


How reproducible:
Almost every time

Steps to Reproduce:
1. See email above
2.
3.


Additional info:
John H. suggested that it was a build problem and that Constants.pm does not have $PS defined.

This is the problem!

Comment 1 Petr Hracek 2014-07-28 13:20:17 UTC

*** This bug has been marked as a duplicate of bug 1074216 ***


Note You need to log in before you can comment on or make changes to this bug.